aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-07-01 20:32:51 -0400
committerAisha Tammy <gentoo@aisha.cc>2020-07-01 20:32:51 -0400
commit234e30342c281b607babbe7b6b1e9ca009099610 (patch)
tree3cff3d9ec2c449164e7f85d18deb7758a4d2b928
parentdev-python/pylatex: vbump 1.3.3 (diff)
downloadguru-234e3034.tar.gz
guru-234e3034.tar.bz2
guru-234e3034.zip
www-apps/uwebsockets: version bump to 18.9.0
Package-Manager: Portage-2.3.101, Repoman-2.3.22 Signed-off-by: Aisha Tammy <gentoo@aisha.cc>
-rw-r--r--www-apps/uwebsockets/Manifest1
-rw-r--r--www-apps/uwebsockets/uwebsockets-18.9.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/www-apps/uwebsockets/Manifest b/www-apps/uwebsockets/Manifest
index b19a744dd..28e76bfbb 100644
--- a/www-apps/uwebsockets/Manifest
+++ b/www-apps/uwebsockets/Manifest
@@ -1 +1,2 @@
DIST uwebsockets-18.8.0.tar.gz 265075 BLAKE2B cad647271aa56c5a66ae149db1cb1f254f3ad27f52ce549dff406f91a0415780bf5375c47facf09bf953d7d75f690243a1f1dfbb94891822d2637ead7559c81c SHA512 9e1741134ca628fc4ed3b634eec57c825af90f1cdccaaee48aa5ba86ee5aef08274fcc1621703d155a9f4a388fddee57c60d333dba985dfcf8b4e6f1870692d9
+DIST uwebsockets-18.9.0.tar.gz 265223 BLAKE2B c7112040e699eeba4aaa753637a4039597979962c6e4815c2f10af993dd0724e5c18c99d3438e3efec5a18878be33cfd7eb641489a4d3546c92c3ad8e7551647 SHA512 c34f7ace7ab5c077ce5f6cc3fbc38323ad34ccf639a77c4b82ee0905ac2910b584140333d9a7afeb53596619baa15ba890ba25c34c3dbcb49e646f9ecff1f362
diff --git a/www-apps/uwebsockets/uwebsockets-18.9.0.ebuild b/www-apps/uwebsockets/uwebsockets-18.9.0.ebuild
new file mode 100644
index 000000000..2738b66dd
--- /dev/null
+++ b/www-apps/uwebsockets/uwebsockets-18.9.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="ultra fast, simple, secure & standards compliant web I/O"
+HOMEPAGE="https://github.com/uNetworking/uWebSockets"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/uNetworking/uWebSockets.git"
+else
+ SRC_URI="https://github.com/uNetworking/uWebSockets/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+ S="${WORKDIR}/uWebSockets-${PV}"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+RDEPEND=">=net-libs/usockets-0.4.1"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-src_Loop.h.patch"
+)
+
+src_prepare() {
+ default
+ mv src uWebSockets
+}
+
+src_compile() {
+ return 0
+}
+
+src_install() {
+ doheader -r uWebSockets
+}