aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-07-05 01:53:47 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-07-05 02:43:18 +0200
commit23977e932ec697c08b0ea2f91ac80f1a4c163209 (patch)
tree3b2ea3f648bb6a9e1dba33fd9bf4e80dbc057296
parentapp-editors/imhex: add github upstream metadata (diff)
downloadguru-23977e93.tar.gz
guru-23977e93.tar.bz2
guru-23977e93.zip
dev-python/pytest-cython: ebuild maintenance
Closes: https://bugs.gentoo.org/800374 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
-rw-r--r--dev-python/pytest-cython/Manifest1
-rw-r--r--dev-python/pytest-cython/pytest-cython-0.1.0-r2.ebuild34
-rw-r--r--dev-python/pytest-cython/pytest-cython-0.1.1.ebuild10
3 files changed, 2 insertions, 43 deletions
diff --git a/dev-python/pytest-cython/Manifest b/dev-python/pytest-cython/Manifest
index 38d733099..f5da597e9 100644
--- a/dev-python/pytest-cython/Manifest
+++ b/dev-python/pytest-cython/Manifest
@@ -1,2 +1 @@
-DIST pytest-cython-0.1.0.tar.gz 19109 BLAKE2B 75895992402f36010385e0851cce4532825d374cc9d5af1b45d4dc938070da1f9e8c9901601ac10e3fa9a76fd4f0affd3f0dac6d8857eea88c73cbc1686ce613 SHA512 65d8d25f95f2419ae76902cad8f0f4c9b810dbbba80621d301f53d2128dfeb11c4d74e2ac4f1e39f63aadfc1404e9000c0668efbab4793d307f0b90345023771
DIST pytest-cython-0.1.1.tar.gz 817776 BLAKE2B d9b812cefc45153a1ce7abb0b1be2e7fc329b88d89ed48529f62a38c402d74bb164ed6b928f291586f0064820dc52156eacdf161da3a0d65d10f5a15681a17e4 SHA512 353a6c3b67df0608b24f24e04ba5d3fa48065d3960834e32bf44f2dfcd6248cb4c86de528c15dbfd20e36811bfb0ae04670f6441afb74bcb7bd1d7af71060463
diff --git a/dev-python/pytest-cython/pytest-cython-0.1.0-r2.ebuild b/dev-python/pytest-cython/pytest-cython-0.1.0-r2.ebuild
deleted file mode 100644
index e9a14cf5d..000000000
--- a/dev-python/pytest-cython/pytest-cython-0.1.0-r2.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-PYTHON_COMPAT=( pypy3 python3_{7,8,9} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1
-
-DESCRIPTION="Plugin for testing Cython extension modules"
-HOMEPAGE="https://github.com/lgpage/pytest-cython"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="~amd64"
-IUSE="test"
-
-#IDK how to run this: python tests/example-project/setup.py clean build_ext --inplace --use-cython
-RESTRICT="test"
-RDEPEND="
- dev-python/cython[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
-"
-DEPEND="
- ${RDEPEND}
-"
-
-src_prepare() {
- sed -i 's|\[pytest\]|\[tool:pytest\]|' setup.cfg || die
- default
-}
-
-distutils_enable_sphinx docs dev-python/sphinx-py3doc-enhanced-theme
diff --git a/dev-python/pytest-cython/pytest-cython-0.1.1.ebuild b/dev-python/pytest-cython/pytest-cython-0.1.1.ebuild
index 1d8fc289c..69c69fa72 100644
--- a/dev-python/pytest-cython/pytest-cython-0.1.1.ebuild
+++ b/dev-python/pytest-cython/pytest-cython-0.1.1.ebuild
@@ -1,10 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="7"
+EAPI="8"
-PYTHON_COMPAT=( pypy3 python3_{8,9} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( pypy3 python3_{8..10} pypy3 )
inherit distutils-r1
@@ -24,11 +23,6 @@ DEPEND="${RDEPEND}"
distutils_enable_sphinx docs dev-python/sphinx-py3doc-enhanced-theme
distutils_enable_tests pytest
-src_prepare() {
- sed -i 's|\[pytest\]|\[tool:pytest\]|' setup.cfg || die
- default
-}
-
python_test() {
epytest -vv \
--deselect tests/test_pytest_cython.py::test_wrap_c_ext_module \