aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-06-18 02:25:59 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-06-18 04:16:53 +0200
commit23c35ced367f1657e32a608ee52ebfc46cb94fb6 (patch)
tree97056aa83762ed9872c7a191de8a92d59573e915
parentdev-python/ufoProcessor: add MutatorMath dep (diff)
downloadguru-23c35ced.tar.gz
guru-23c35ced.tar.bz2
guru-23c35ced.zip
dev-python/unicodedata2: initial import
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
-rw-r--r--dev-python/unicodedata2/Manifest1
-rw-r--r--dev-python/unicodedata2/metadata.xml5
-rw-r--r--dev-python/unicodedata2/unicodedata2-13.0.0.2.ebuild18
3 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/unicodedata2/Manifest b/dev-python/unicodedata2/Manifest
new file mode 100644
index 0000000000..3c5965e05e
--- /dev/null
+++ b/dev-python/unicodedata2/Manifest
@@ -0,0 +1 @@
+DIST unicodedata2-13.0.0.2.tar.gz 1202880 BLAKE2B 237a1be7a22a9aaaa3e417a14687e7169630632a3fed90dbda963c5ef6994cbac45e67c7930529362c438a8a20251c64979b3baeaa963dd40e70bd453d2ceb77 SHA512 451a49a9e29935c59932804d8a821562f07ea22658fe57a472eed9a5eacfc9c7c497f25c084451c90cf0992638956ac51572f0c52e74452ece7d66c052d82641
diff --git a/dev-python/unicodedata2/metadata.xml b/dev-python/unicodedata2/metadata.xml
new file mode 100644
index 0000000000..c6442c759f
--- /dev/null
+++ b/dev-python/unicodedata2/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<!-- maintainer-needed -->
+</pkgmetadata>
diff --git a/dev-python/unicodedata2/unicodedata2-13.0.0.2.ebuild b/dev-python/unicodedata2/unicodedata2-13.0.0.2.ebuild
new file mode 100644
index 0000000000..9861bbeb87
--- /dev/null
+++ b/dev-python/unicodedata2/unicodedata2-13.0.0.2.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MYPV="$(ver_rs 3 -)"
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+SRC_URI="https://github.com/mikekap/unicodedata2/archive/refs/tags/${MYPV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+DESCRIPTION="Unicodedata backport for python 2/3 updated to the latest unicode version"
+HOMEPAGE="https://github.com/mikekap/unicodedata2"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+distutils_enable_tests pytest