aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2022-08-28 19:26:26 +0200
committerHaelwenn (lanodan) Monnier <contact@hacktivis.me>2022-08-30 00:49:28 +0200
commit243e1af5f22369b43b2afadd6b784a803329c056 (patch)
tree5fff699dcb88af7daeb70cad32e7646193b089b4
parentdev-python/wheezy-template: new package, add 3.1.0 (diff)
downloadguru-243e1af5.tar.gz
guru-243e1af5.tar.bz2
guru-243e1af5.zip
dev-python/schema: new package, add 0.7.5
Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me>
-rw-r--r--dev-python/schema/Manifest1
-rw-r--r--dev-python/schema/schema-0.7.5.ebuild18
2 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/schema/Manifest b/dev-python/schema/Manifest
new file mode 100644
index 000000000..49a96927b
--- /dev/null
+++ b/dev-python/schema/Manifest
@@ -0,0 +1 @@
+DIST schema-0.7.5.tar.gz 48173 BLAKE2B 3d112ee1960c79a64ec2980cbd70403b6dbcafdeeb4f5826c427426aafd602691fd5ceab408edf88e50854a7d66306a73a4729c056a1ca7d1eaa4d0c725901a9 SHA512 10184a4d2a30600d5c6fe9fcde33925137825e811af691c40fee841f88e4a5106ef7e79be2a0ddddd0e0b74892bf889c3d2eff934a36dbca269cd7bf22748d39
diff --git a/dev-python/schema/schema-0.7.5.ebuild b/dev-python/schema/schema-0.7.5.ebuild
new file mode 100644
index 000000000..507911b44
--- /dev/null
+++ b/dev-python/schema/schema-0.7.5.ebuild
@@ -0,0 +1,18 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517="setuptools"
+PYTHON_COMPAT=( python3_{8,9,10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module to validate and convert data structures"
+HOMEPAGE="https://github.com/keleshev/schema"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64"
+LICENSE="MIT"
+SLOT="0"
+
+distutils_enable_tests pytest