aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2020-03-29 11:28:02 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2020-03-29 11:29:04 +0200
commit261df3eb62bc415489e08cbb84ab8cc5401df969 (patch)
treedf2727f8d307e0d38d8e45c825e4361cc15b075b
parentdev-python/autoflake: new package (diff)
downloadguru-261df3eb62bc415489e08cbb84ab8cc5401df969.tar.gz
guru-261df3eb62bc415489e08cbb84ab8cc5401df969.tar.bz2
guru-261df3eb62bc415489e08cbb84ab8cc5401df969.zip
dev-python/httpcore: new package
Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
-rw-r--r--dev-python/httpcore/Manifest1
-rw-r--r--dev-python/httpcore/httpcore-0.7.0.ebuild49
-rw-r--r--dev-python/httpcore/metadata.xml26
3 files changed, 76 insertions, 0 deletions
diff --git a/dev-python/httpcore/Manifest b/dev-python/httpcore/Manifest
new file mode 100644
index 000000000..82c23f38e
--- /dev/null
+++ b/dev-python/httpcore/Manifest
@@ -0,0 +1 @@
+DIST httpcore-0.7.0.tar.gz 24689 BLAKE2B 5a7fa8eab6dc166f96c1a71d2ce1980155c37e286421fe10ff17315680d5a1ba5a6b52a8e0bcf8f727cdb146971ea82942327a900408ab72f8c82e2bfc9f9f83 SHA512 4999900e23aa9750f830e0d521db51e606c5b43e254cad8b98c17c2d3e4b2bd59020308954f5411ad766bff1759e2812a5b5e313273be22002dd87a75ea2413a
diff --git a/dev-python/httpcore/httpcore-0.7.0.ebuild b/dev-python/httpcore/httpcore-0.7.0.ebuild
new file mode 100644
index 000000000..acaa8e18e
--- /dev/null
+++ b/dev-python/httpcore/httpcore-0.7.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_6 )
+
+inherit distutils-r1
+
+DESCRIPTION="A minimal HTTP client"
+HOMEPAGE="
+ https://github.com/encode/httpcore
+ https://pypi.org/project/httpcore
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/h11[${PYTHON_USEDEP}]
+ dev-python/hyper-h2[${PYTHON_USEDEP}]
+ dev-python/sniffio[${PYTHON_USEDEP}]
+ dev-python/trio[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ doc? (
+ dev-python/mkautodoc
+ dev-python/mkdocs
+ dev-python/mkdocs-material
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/autoflake[${PYTHON_USEDEP}]
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/isort[${PYTHON_USEDEP}]
+ dev-python/mypy[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-trio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+#todo doc
diff --git a/dev-python/httpcore/metadata.xml b/dev-python/httpcore/metadata.xml
new file mode 100644
index 000000000..8b1dc8362
--- /dev/null
+++ b/dev-python/httpcore/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>lssndrbarbieri@gmail.com</email>
+ <name>Alessandro Barbieri</name>
+ </maintainer>
+ <longdescription lang="en">
+The HTTP Core package provides a minimal low-level HTTP client, which does one thing only. Sending HTTP requests.
+
+It does not provide any high level model abstractions over the API, does not handle redirects, multipart uploads, building authentication headers, transparent HTTP caching, URL parsing, session cookie handling, content or charset decoding, handling JSON, environment based configuration defaults, or any of that Jazz.
+
+Some things HTTP Core does do:
+
+ Sending HTTP requests.
+ Provides both sync and async interfaces.
+ Supports HTTP/1.1 and HTTP/2.
+ Async backend support for asyncio and trio.
+ Automatic connection pooling.
+ HTTP(S) proxy support.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">https://github.com/encode/httpcore</remote-id>
+ <remote-id type="pypi">httpcore</remote-id>
+ </upstream>
+</pkgmetadata>