aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny (tastytea) Gutbrod <gentoo@tastytea.de>2021-12-20 01:28:24 +0100
committerRonny (tastytea) Gutbrod <gentoo@tastytea.de>2021-12-21 12:44:28 +0100
commit26e4f8b6dd47c686e10e0bd628bf1c6b669ddb47 (patch)
tree61a444e999019cfdbb98ab47db5c51a8f014e629
parentapp-vim/css-color: add 20211219 (diff)
downloadguru-26e4f8b6dd47c686e10e0bd628bf1c6b669ddb47.tar.gz
guru-26e4f8b6dd47c686e10e0bd628bf1c6b669ddb47.tar.bz2
guru-26e4f8b6dd47c686e10e0bd628bf1c6b669ddb47.zip
dev-cpp/qt-jdenticon: Version bump 0.3.0
Signed-off-by: Ronny (tastytea) Gutbrod <gentoo@tastytea.de>
-rw-r--r--dev-cpp/qt-jdenticon/Manifest1
-rw-r--r--dev-cpp/qt-jdenticon/qt-jdenticon-0.3.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-cpp/qt-jdenticon/Manifest b/dev-cpp/qt-jdenticon/Manifest
index bfeb60512..d9e190417 100644
--- a/dev-cpp/qt-jdenticon/Manifest
+++ b/dev-cpp/qt-jdenticon/Manifest
@@ -1 +1,2 @@
DIST qt-jdenticon-0.2.1.tar.gz 11590 BLAKE2B 0884fe3ab8f2e9f62c1592f96a311bec8992f6230bafe6a82f4fc67995fca4e2ac8677e22df3c69ecd9a9e3e35d6d0fb695d34aa69646c472cb78ec8c4cad4cc SHA512 22194dfbf4baf3cab4a4b51457a79538f9fdc62fc5a26c5492b76ce88c98b61c7cdd29dd42a3a886d9f755163ae9bd30f67cc5c3376e8c0a17e438e53b833740
+DIST qt-jdenticon-0.3.0.tar.gz 11021 BLAKE2B c4cbeba7848791b2386ac474ca7412b361ee949a126f10cdb523210a8415b436c365a3c056ca3fa9c196835f6bfc92b24a01f2906e62897b88af2e80a83d3bb3 SHA512 a3477ce8fd26de563c1397a07895dcd0ec8210c62fe82e808a8c322c298111c48570ce23df639d648d86a0627b455dc7d1772e985197351251d49abd461b8c23
diff --git a/dev-cpp/qt-jdenticon/qt-jdenticon-0.3.0.ebuild b/dev-cpp/qt-jdenticon/qt-jdenticon-0.3.0.ebuild
new file mode 100644
index 000000000..f7916f42f
--- /dev/null
+++ b/dev-cpp/qt-jdenticon/qt-jdenticon-0.3.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qmake-utils
+
+DESCRIPTION="Qt5 / C++14 Port of Jdenticon"
+HOMEPAGE="https://github.com/Nheko-Reborn/qt-jdenticon"
+SRC_URI="https://github.com/Nheko-Reborn/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-qt/qtgui
+"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ eqmake5
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+}