aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-10-05 22:53:04 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-10-05 23:24:13 +0200
commit2761a6c52a0bffbdba01b3bbcefeeba8d7d4e800 (patch)
treee0a195d79b23a51e699f664088d0e3d342bced47
parentsci-libs/ensmallen: drop 2.14.2, 2.15.0, 2.15.1, 2.16.0 (diff)
downloadguru-2761a6c5.tar.gz
guru-2761a6c5.tar.bz2
guru-2761a6c5.zip
sci-libs/ensmallen: add 2.17.0
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
-rw-r--r--sci-libs/ensmallen/Manifest1
-rw-r--r--sci-libs/ensmallen/ensmallen-2.17.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/sci-libs/ensmallen/Manifest b/sci-libs/ensmallen/Manifest
index a8bcc31fa..f69c4c39a 100644
--- a/sci-libs/ensmallen/Manifest
+++ b/sci-libs/ensmallen/Manifest
@@ -1 +1,2 @@
DIST ensmallen-2.16.2.tar.gz 1294240 BLAKE2B b388f2c99f289dd20f6d94b5b185d872abc553637c6081ea3a80a3c82ce9ac8b1327496bf3eae6dc5cbf5f4ae12a9fd1e8ccf9c296007f9af9cbfc7560cd0301 SHA512 290932f8e423be7c57d8ba38783a29798df52a7505ded7683f969fa30391398edcca584daca1b1c42977f06180a802d4c3640a9ec24cd787a3914723e4eb6f8d
+DIST ensmallen-2.17.0.tar.gz 1318322 BLAKE2B cb74a3bc0118c9e702cc7e4d17326f12df45d5fadc63c8881c5dd2b9a79b004189369e1c7fcb2fc84e0bf7331da3937bffdf75b982de52314487f25191053164 SHA512 49dff47d50beabc74c0eb045f0e995348bc1cc022596de1780cad3e8fc6e6ef6cf97fb23f22c78a0662c377c1dd53d087df799d0fa98ebcc97c03c475b67fd07
diff --git a/sci-libs/ensmallen/ensmallen-2.17.0.ebuild b/sci-libs/ensmallen/ensmallen-2.17.0.ebuild
new file mode 100644
index 000000000..2dc0d0e83
--- /dev/null
+++ b/sci-libs/ensmallen/ensmallen-2.17.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="header only C++ library for numerical optimization"
+HOMEPAGE="https://ensmallen.org"
+SRC_URI="https://github.com/mlpack/ensmallen/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="openmp test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="sci-libs/armadillo[lapack]"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_OPENMP=$(usex openmp)
+ -DBUILD_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}