aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNickolas Raymond Kaczynski <nrk@disroot.org>2021-07-30 21:52:02 +0600
committerNickolas Raymond Kaczynski <nrk@disroot.org>2021-07-30 21:52:02 +0600
commit2814d0e7a412801d30163917156e322b5700132b (patch)
treed1d91d1bdd6ed17071eb031ee51a10ef4d86ad85
parentnet-news/sfeed: bump version v0.9.25 (diff)
downloadguru-2814d0e7a412801d30163917156e322b5700132b.tar.gz
guru-2814d0e7a412801d30163917156e322b5700132b.tar.bz2
guru-2814d0e7a412801d30163917156e322b5700132b.zip
x11-misc/xbanish: add new package
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Nickolas Raymond Kaczynski <nrk@disroot.org>
-rw-r--r--x11-misc/xbanish/Manifest1
-rw-r--r--x11-misc/xbanish/metadata.xml10
-rw-r--r--x11-misc/xbanish/xbanish-1.7.ebuild42
3 files changed, 53 insertions, 0 deletions
diff --git a/x11-misc/xbanish/Manifest b/x11-misc/xbanish/Manifest
new file mode 100644
index 0000000000..3d9b16c823
--- /dev/null
+++ b/x11-misc/xbanish/Manifest
@@ -0,0 +1 @@
+DIST v1.7.tar.gz 6379 BLAKE2B b5c2da9890676be642d963147b38585089160bbeb8609e66e586ce69b886e39e4b02e60e1c4554fb27454ae3bc89c7169f5b1ece3e511e327ee0bfbef25035c3 SHA512 f790ea888812bb6b7793f0a60a900724fc407ec4485672e37d464387ffacfa4bf2dc891862f3fed06948cda31024745816b3adb58074c4578edc6a9848f2bd08
diff --git a/x11-misc/xbanish/metadata.xml b/x11-misc/xbanish/metadata.xml
new file mode 100644
index 0000000000..2018f28ad6
--- /dev/null
+++ b/x11-misc/xbanish/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>nrk@disroot.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">jcs/xbanish</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-misc/xbanish/xbanish-1.7.ebuild b/x11-misc/xbanish/xbanish-1.7.ebuild
new file mode 100644
index 0000000000..414181e9d5
--- /dev/null
+++ b/x11-misc/xbanish/xbanish-1.7.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Banish the mouse cursor when typing, show it again when the mouse moves"
+HOMEPAGE="https://github.com/jcs/xbanish"
+
+SRC_URI="${HOMEPAGE}/archive/v${PV}.tar.gz"
+
+KEYWORDS="~amd64"
+# NOTE: Upstream moved to ISC license on master.
+# So this needs to be changed on the next version (1.7+).
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+# NOTE: x11-libs/libXext might become a dep next version (1.7+)
+DEPEND="
+ x11-libs/libX11
+ x11-libs/libXfixes
+ x11-libs/libXi
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ # Makefile doesn't respect user's LDFLAGS
+ sed -i \
+ -e 's|\$(LIBS) |\$(LIBS) $(LDFLAGS) |g' \
+ Makefile || die "sed failed"
+}
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}
+
+src_install() {
+ dobin xbanish
+ doman xbanish.1
+}