aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbrettalcox <brettalcox@gmail.com>2023-12-07 19:22:24 -0600
committerbrettalcox <brettalcox@gmail.com>2023-12-07 19:22:24 -0600
commit296f305c9e1a6c3d704557f1edfcb1e0fd1d121e (patch)
treef1c9faca71a17ae6be8ef17d75c5859f7a6cea4b
parentgames-emulation/mupen64plus-qt: adjust quazip / qt5 dependency (diff)
downloadguru-296f305c.tar.gz
guru-296f305c.tar.bz2
guru-296f305c.zip
dev-cpp/tomlplusplus: new package, add 3.4.0
Signed-off-by: brettalcox <brettalcox@gmail.com>
-rw-r--r--dev-cpp/tomlplusplus/Manifest1
-rw-r--r--dev-cpp/tomlplusplus/metadata.xml10
-rw-r--r--dev-cpp/tomlplusplus/tomlplusplus-3.4.0.ebuild20
3 files changed, 31 insertions, 0 deletions
diff --git a/dev-cpp/tomlplusplus/Manifest b/dev-cpp/tomlplusplus/Manifest
new file mode 100644
index 0000000000..e56e8881ad
--- /dev/null
+++ b/dev-cpp/tomlplusplus/Manifest
@@ -0,0 +1 @@
+DIST tomlplusplus-3.4.0.tar.gz 1294731 BLAKE2B 9495ccd78707ced11744eab7c1c0bf0c0c28e283d186195bb48d1059bae7eb1a874bc964b0fc45210fd73ffd7485ecf3e1159da227d0e1c8ff249e79c08eecf0 SHA512 c227fc8147c9459b29ad24002aaf6ab2c42fac22ea04c1c52b283a0172581ccd4527b33c1931e0ef0d1db6b6a53f9e9882c6d4231c7f3494cf070d0220741aa5
diff --git a/dev-cpp/tomlplusplus/metadata.xml b/dev-cpp/tomlplusplus/metadata.xml
new file mode 100644
index 0000000000..0a17b284ff
--- /dev/null
+++ b/dev-cpp/tomlplusplus/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM 'https://www.gentoo.org/dtd/metadata.dtd'>
+<pkgmetadata>
+ <maintainer type="person">
+ <email>brettalcox@gmail.com</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">marzer/tomlplusplus.git</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-cpp/tomlplusplus/tomlplusplus-3.4.0.ebuild b/dev-cpp/tomlplusplus/tomlplusplus-3.4.0.ebuild
new file mode 100644
index 0000000000..dccc0317a7
--- /dev/null
+++ b/dev-cpp/tomlplusplus/tomlplusplus-3.4.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="TOML config parser and serializer for C++"
+HOMEPAGE="https://github.com/marzer/tomlplusplus.git"
+SRC_URI="https://github.com/marzer/tomlplusplus/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-util/cmake
+ dev-util/meson
+"