aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-04-28 19:23:14 +0200
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-04-28 19:23:14 +0200
commit2a3d27c98ca429625ab6e7eac0f0b0f9fc124581 (patch)
tree7ddef8f60a8a3f6e26299da0b2daca0db8874c62
parentdev-python/pydantic: Data parsing and validation using type hints (diff)
downloadguru-2a3d27c9.tar.gz
guru-2a3d27c9.tar.bz2
guru-2a3d27c9.zip
dev-python/pytest-toolbox: Numerous useful plugins for pytest
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
-rw-r--r--dev-python/pytest-toolbox/Manifest1
-rw-r--r--dev-python/pytest-toolbox/metadata.xml13
-rw-r--r--dev-python/pytest-toolbox/pytest-toolbox-0.4.ebuild41
3 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/pytest-toolbox/Manifest b/dev-python/pytest-toolbox/Manifest
new file mode 100644
index 000000000..2bb1bbe60
--- /dev/null
+++ b/dev-python/pytest-toolbox/Manifest
@@ -0,0 +1 @@
+DIST pytest-toolbox-0.4.tar.gz 8594 BLAKE2B fb1f19513e9e4b191c3eb995cc5e9445bc9f19affef87350d925c5465210c4de945b91120f86664c1dcf02a638595a7725cf88e3244e377ae77558c70d65643a SHA512 ed27700ff77cd607be808142cc310cd2b7461e55b3f8352d304ef8ca6c5e6c060c67a63238a1025407868ab8e229c4a16eaaa56aa75000159762001accb67752
diff --git a/dev-python/pytest-toolbox/metadata.xml b/dev-python/pytest-toolbox/metadata.xml
new file mode 100644
index 000000000..2bea5658e
--- /dev/null
+++ b/dev-python/pytest-toolbox/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>andrewammerlaan@riseup.net</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">samuelcolvin/pytest-toolbox</remote-id>
+ <remote-id type="pypi">pytest-toolbox</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-toolbox/pytest-toolbox-0.4.ebuild b/dev-python/pytest-toolbox/pytest-toolbox-0.4.ebuild
new file mode 100644
index 000000000..8a8594540
--- /dev/null
+++ b/dev-python/pytest-toolbox/pytest-toolbox-0.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Numerous useful plugins for pytest"
+HOMEPAGE="https://github.com/samuelcolvin/pytest-toolbox"
+SRC_URI="https://github.com/samuelcolvin/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+distutils_enable_tests pytest
+
+DEPEND="test? (
+ dev-python/isort[${PYTHON_USEDEP}]
+ dev-python/pydantic[${PYTHON_USEDEP}]
+ dev-python/pytest-isort[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+)"
+
+RDEPEND="
+ >=dev-python/pytest-3.5.0[${PYTHON_USEDEP}]
+ <=dev-python/pytest-5[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ # pytest.warning_types.PytestAssertRewriteWarning: asserting the value None, please use "assert is None"
+ sed -i -e 's:test_is_uuid_false:_&:' \
+ -e 's:test_any_int_false:_&:' \
+ tests/test_comparison.py || die
+
+ distutils-r1_python_prepare_all
+}