aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-04-03 09:55:42 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-04-04 01:46:08 +0200
commit2af0b71b5b88f92fe10289f6d75e2628e5c60daa (patch)
tree2ac958289987ff30a404d448dc51672626e16a4e
parentdev-ml/shared-memory-ring: initial import (diff)
downloadguru-2af0b71b.tar.gz
guru-2af0b71b.tar.bz2
guru-2af0b71b.zip
dev-ml/mirage-profile: initial import
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
-rw-r--r--dev-ml/mirage-profile/Manifest1
-rw-r--r--dev-ml/mirage-profile/metadata.xml14
-rw-r--r--dev-ml/mirage-profile/mirage-profile-0.9.0-r2.ebuild39
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-ml/mirage-profile/Manifest b/dev-ml/mirage-profile/Manifest
new file mode 100644
index 0000000000..0add7acf48
--- /dev/null
+++ b/dev-ml/mirage-profile/Manifest
@@ -0,0 +1 @@
+DIST mirage-profile-0.9.0.tar.gz 11633 BLAKE2B d55b73be2df42230666577be11e1c9138cadc8e1d895a1b58cec342adfac165c76a405298cd24d2d21e6caad12b9593599ba4c62c459e51cf9be58409edfb425 SHA512 9a1ba91cfe1454aa85a6f1f72c934d413a8bc4f4793689f309abeca9be22c66c3c3213e8d360ea62813c019e064573cb250d835656c6302429b8e7cbdb39fa2c
diff --git a/dev-ml/mirage-profile/metadata.xml b/dev-ml/mirage-profile/metadata.xml
new file mode 100644
index 0000000000..7f44c78f27
--- /dev/null
+++ b/dev-ml/mirage-profile/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>lssndrbarbieri@gmail.com</email>
+ <name>Alessandro Barbieri</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">mirage/mirage-profile</remote-id>
+ </upstream>
+ <use>
+ <flag name="xen">Adds a Xen MirageOS backend collector</flag>
+ </use>
+</pkgmetadata>
diff --git a/dev-ml/mirage-profile/mirage-profile-0.9.0-r2.ebuild b/dev-ml/mirage-profile/mirage-profile-0.9.0-r2.ebuild
new file mode 100644
index 0000000000..b5f8080af1
--- /dev/null
+++ b/dev-ml/mirage-profile/mirage-profile-0.9.0-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune multiprocessing
+
+DESCRIPTION="Collect profiling information"
+HOMEPAGE="https://github.com/mirage/mirage-profile"
+SRC_URI="https://github.com/mirage/mirage-profile/archive/v${PV}.tar.gz -> mirage-profile-${PV}.tar.gz"
+S="${WORKDIR}/mirage-profile-${PV}"
+
+LICENSE="BSD-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="ocamlopt xen"
+
+RDEPEND="
+ dev-ml/mtime
+ dev-ml/io-page
+ dev-ml/ocplib-endian
+
+ xen? (
+ dev-ml/mirage-xen
+ dev-ml/xenstore
+ )
+"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ local pkgs="mirage-profile-unix,mirage-profile"
+ use xen && pkgs="${pkgs},mirage-profile-xen"
+ dune build --only-packages "${pkgs}" -j $(makeopts_jobs) --profile release || die
+}
+
+src_install() {
+ dune_src_install mirage-profile mirage-profile-unix
+ use xen && dune_src_install mirage-profile-xen
+}