aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Torokhov <torokhov-s-a@yandex.ru>2022-04-29 20:42:37 +0300
committerSergey Torokhov <torokhov-s-a@yandex.ru>2022-04-29 20:42:37 +0300
commit2af33a430c9ed23e2c5c2fdc13904e3196f4a01f (patch)
tree30cc4bf3338d1a1d76309544ef22d4bc7967c41d
parentnet-libs/ixwebsocket: add 11.4.2, drop 11.4.1 (diff)
downloadguru-2af33a43.tar.gz
guru-2af33a43.tar.bz2
guru-2af33a43.zip
app-doc/ford: pass name of the system C preprocessor
Closes: https://bugs.gentoo.org/839300 Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru>
-rw-r--r--app-doc/ford/ford-6.1.10.ebuild7
-rw-r--r--app-doc/ford/ford-6.1.11.ebuild7
-rw-r--r--app-doc/ford/ford-6.1.8.ebuild7
3 files changed, 18 insertions, 3 deletions
diff --git a/app-doc/ford/ford-6.1.10.ebuild b/app-doc/ford/ford-6.1.10.ebuild
index 369eb1f96..66ccc5ab8 100644
--- a/app-doc/ford/ford-6.1.10.ebuild
+++ b/app-doc/ford/ford-6.1.10.ebuild
@@ -4,7 +4,7 @@
EAPI=8
PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
+inherit distutils-r1 toolchain-funcs
MY_PN="FORD"
DESCRIPTION="FORD, automatic documentation generator for modern Fortran programs"
@@ -36,6 +36,11 @@ DOCS=( CHANGELOG.md README.md README.rst )
distutils_enable_tests pytest
+src_prepare() {
+ default
+ sed -i -e 's/"cpp /"'"$(tc-getCPP)"' /' ford/__init__.py || die # bug: 839300
+}
+
python_test(){
# The 'test/test_projects' tests use subprocess, i.e. require FORD to be installed.
distutils_install_for_testing
diff --git a/app-doc/ford/ford-6.1.11.ebuild b/app-doc/ford/ford-6.1.11.ebuild
index 369eb1f96..66ccc5ab8 100644
--- a/app-doc/ford/ford-6.1.11.ebuild
+++ b/app-doc/ford/ford-6.1.11.ebuild
@@ -4,7 +4,7 @@
EAPI=8
PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
+inherit distutils-r1 toolchain-funcs
MY_PN="FORD"
DESCRIPTION="FORD, automatic documentation generator for modern Fortran programs"
@@ -36,6 +36,11 @@ DOCS=( CHANGELOG.md README.md README.rst )
distutils_enable_tests pytest
+src_prepare() {
+ default
+ sed -i -e 's/"cpp /"'"$(tc-getCPP)"' /' ford/__init__.py || die # bug: 839300
+}
+
python_test(){
# The 'test/test_projects' tests use subprocess, i.e. require FORD to be installed.
distutils_install_for_testing
diff --git a/app-doc/ford/ford-6.1.8.ebuild b/app-doc/ford/ford-6.1.8.ebuild
index a0e690c66..db76d2774 100644
--- a/app-doc/ford/ford-6.1.8.ebuild
+++ b/app-doc/ford/ford-6.1.8.ebuild
@@ -4,7 +4,7 @@
EAPI=8
PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
+inherit distutils-r1 toolchain-funcs
MY_PN="FORD"
DESCRIPTION="FORD, automatic documentation generator for modern Fortran programs"
@@ -41,6 +41,11 @@ EPYTEST_IGNORE=(
test/test_projects/test_external_project.py
)
+src_prepare() {
+ default
+ sed -i -e 's/"cpp /"'"$(tc-getCPP)"' /' ford/__init__.py || die # bug: 839300
+}
+
python_test(){
# The 'test/test_projects' tests use subprocess, i.e. require FORD to be installed.
distutils_install_for_testing