aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-03-09 17:38:35 +0100
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-03-09 17:38:35 +0100
commit2bc209fb011e87ee41f7bf2111eb68a0187f913d (patch)
tree76ed5e7552aad8b549b3258e4da18cc724c8cbb7
parentdev-python/trio: Python library for async concurrency and I/O (diff)
downloadguru-2bc209fb.tar.gz
guru-2bc209fb.tar.bz2
guru-2bc209fb.zip
dev-python/tekore: depend on dataclasses if py3_6
Package-Manager: Portage-2.3.93, Repoman-2.3.20 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
-rw-r--r--dev-python/tekore/tekore-1.4.0.ebuild23
1 files changed, 7 insertions, 16 deletions
diff --git a/dev-python/tekore/tekore-1.4.0.ebuild b/dev-python/tekore/tekore-1.4.0.ebuild
index 88c60d073f..93f8f55ce0 100644
--- a/dev-python/tekore/tekore-1.4.0.ebuild
+++ b/dev-python/tekore/tekore-1.4.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_7 )
+PYTHON_COMPAT=( python3_{6,7} )
inherit distutils-r1
@@ -16,25 +16,16 @@ LICENSE="MIT"
KEYWORDS="~amd64 ~x86"
SLOT="0"
-distutils_enable_sphinx docs/src
-
-# the enable_sphinx fucntion seems to act strange when there is only 1 PYTHON_COMPAT
-# repoman says:
-# dev-python/tekore/tekore-1.1.0.ebuild: BDEPEND: ~x86(default/linux/x86/17.0/systemd)
-# [ 'dev-python/sphinx[python_targets_python3_7(-),python_single_target_python3_7(+)]']
-# therefore we overwrite the deps that the function adds here:
-BDEPEND="doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
- dev-python/sphinx-autodoc-typehints[${PYTHON_USEDEP}] )"
-
-RDEPEND="dev-python/requests[${PYTHON_USEDEP}]
- dev-python/httpx[${PYTHON_USEDEP}]
- media-sound/spotify"
+RDEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]
+ ~dev-python/httpx-0.11.1[${PYTHON_USEDEP}]
+ media-sound/spotify
+ python_targets_python3_6? ( dev-python/dataclasses[python_targets_python3_6] )"
DOCS="readme.rst"
distutils_enable_tests pytest
+distutils_enable_sphinx docs/src dev-python/sphinx_rtd_theme dev-python/sphinx-autodoc-typehints
python_test() {
pytest -vv tests/* || die "Tests fail with ${EPYTHON}"