aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-04-24 20:45:57 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-04-24 20:51:42 +0200
commit2c039b70f0366f338ad65a434f402e7d32972d77 (patch)
tree813612ad4e14ecfee218e652329e043f454de31c
parentdev-python/trueskill: fix deps (diff)
downloadguru-2c039b70.tar.gz
guru-2c039b70.tar.bz2
guru-2c039b70.zip
sys-cluster/extrae: preparation for aspectj support
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
-rw-r--r--sys-cluster/extrae/extrae-3.8.3-r1.ebuild16
-rw-r--r--sys-cluster/extrae/metadata.xml1
2 files changed, 14 insertions, 3 deletions
diff --git a/sys-cluster/extrae/extrae-3.8.3-r1.ebuild b/sys-cluster/extrae/extrae-3.8.3-r1.ebuild
index d0518e68f..f1781b099 100644
--- a/sys-cluster/extrae/extrae-3.8.3-r1.ebuild
+++ b/sys-cluster/extrae/extrae-3.8.3-r1.ebuild
@@ -14,7 +14,10 @@ LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64"
IUSE="boost doc dwarf elf fft heterogeneous inotify +instrument-dynamic-memory +instrument-io +instrument-syscall merge-in-trace nanos opencl openmp +parallel-merge pebs-sampling +posix-clock pthread sampling +single-mpi-lib smpss +xml"
-#aspectj and aspectj-weaver needs to be enabled both at the same time but the aspectj package in gentoo doesn't have weaver
+#aspectj and aspectj-weaver need to both be enabled at the same time
+#current dev-java/aspectj package only provides aspectj.jar
+#aspectj needs foo/lib/aspectj.jar and foo/bin/ajc
+#aspectj-weaver needs bar/aspectjweaver.jar
#TODO: find out who is pulling in libpfm
#TODO: find out which FFT library is used
#TODO: remove some useflags (boost fft elf dwarf)
@@ -42,6 +45,7 @@ CDEPEND="
inotify? ( dev-libs/libevent )
opencl? ( dev-util/opencl-headers )
"
+# aspectj? ( >=dev-java/aspectj-1.9.6 )
DEPEND="
${CDEPEND}
java? ( virtual/jdk:1.8 )
@@ -56,6 +60,7 @@ BDEPEND="
"
REQUIRED_USE="
${PYTHON_REQUIRED_USE}
+ java? ( pthread )
"
# cupti? ( cuda )
# dyninst? ( boost dwarf elf )
@@ -92,8 +97,6 @@ src_configure() {
--without-cupti
--without-memkind
--without-clustering
- --without-java-aspectj
- --without-java-aspectj-weaver
--without-synapse
--without-spectral
--without-openshmem
@@ -121,6 +124,13 @@ src_configure() {
# --without-sionlib
#--with-pmpi-hook (Choose method to call PMPI (dlsym or pmpi))
+# if use aspectj; then
+# myconf+=( "--with-java-aspectj=${EPREFIX}/usr/share/aspectj/lib" )
+# myconf+=( "--with-java-aspectj-weaver=${EPREFIX}/usr" )
+# else
+ myconf+=( "--without-java-aspectj-weaver" )
+ myconf+=( "--without-java-aspectj" )
+# fi
if use boost; then
myconf+=( "--with-boost=${EPREFIX}/usr" )
else
diff --git a/sys-cluster/extrae/metadata.xml b/sys-cluster/extrae/metadata.xml
index fb390763b..6022df6bb 100644
--- a/sys-cluster/extrae/metadata.xml
+++ b/sys-cluster/extrae/metadata.xml
@@ -16,6 +16,7 @@ process). Extrae generates trace files that can be later visualized with <pkg>sy
<remote-id type="github">bsc-performance-tools/extrae</remote-id>
</upstream>
<use>
+ <!--<flag name="aspectj">Enable support for tracing Java through <pkg>dev-java/aspectj</pkg> (experimental)</flag>-->
<flag name="boost">Search for boost</flag>
<flag name="doc">Generates the documentation of this instrumentation package</flag>
<!--<flag name="cuda">Enable support for tracing CUDA calls on nVidia hardware and needs to point to the CUDA SDK installation path. This instrumentation is only valid in binaries that use the shared version of the CUDA library.</flag>-->