aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-06-28 06:19:20 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-06-28 06:34:28 +0200
commit2c950777fc56b435d5fcaa8d4cf69d7b1f07f664 (patch)
treefb57b34aafb22276b72876414154ede1d9bb3a32
parentdev-python/hyperglot: add 0.3.9 (diff)
downloadguru-2c950777.tar.gz
guru-2c950777.tar.bz2
guru-2c950777.zip
dev-python/glyphsets: add 0.5.1
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
-rw-r--r--dev-python/glyphsets/Manifest1
-rw-r--r--dev-python/glyphsets/glyphsets-0.5.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/glyphsets/Manifest b/dev-python/glyphsets/Manifest
index 6a1b8f7a7..4267e053c 100644
--- a/dev-python/glyphsets/Manifest
+++ b/dev-python/glyphsets/Manifest
@@ -1 +1,2 @@
DIST glyphsets-0.5.0.gh.tar.gz 1473150 BLAKE2B d745b7689c9eee7cd1a25035d13f19d6eb6db7c8e603ecf87ed689f0cb2e2d1a421b4d5a4f08c7d470def2d5d8db7636a01941f3445579a0712f2ab506a9571a SHA512 94d6ab956a5ab16f061b57e5210ea59733486a27bde3093e8af279ac8f5f1e2efce71d5135ac7182ec027916e31d86433939e743084c405653250893d9221a02
+DIST glyphsets-0.5.1.gh.tar.gz 1473698 BLAKE2B 414ac3c1647ab483545d65f7503c84f19f9d2a0132d246011f88dd11835a297657a16873645d8dc383a77658f275983546b91b96d9c2fa15f47d8fc03562e027 SHA512 9237a2ee86ba25f5023f3ea863739b06374fb16d1655458fdc680b64cb54a1cec0134a2826b4cd1646bae70a33def601d547d2b2432275d68f0c6eb472ea376a
diff --git a/dev-python/glyphsets/glyphsets-0.5.1.ebuild b/dev-python/glyphsets/glyphsets-0.5.1.ebuild
new file mode 100644
index 000000000..a0f0924f2
--- /dev/null
+++ b/dev-python/glyphsets/glyphsets-0.5.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A python API for evaluating coverage of glyph sets in font projects"
+HOMEPAGE="
+ https://github.com/googlefonts/glyphsets
+ https://pypi.org/project/glyphsets/
+"
+SRC_URI="https://github.com/googlefonts/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64"
+SLOT="0"
+
+#ufoLib2 is an indirect dependency
+RDEPEND="
+ dev-python/fonttools[${PYTHON_USEDEP}]
+ dev-python/ufoLib2[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ >=dev-python/setuptools_scm-4[${PYTHON_USEDEP}]
+"
+
+PATCHES=( "${FILESDIR}/${P}-remove-setuptools_scm.constraint.patch" )
+
+python_prepare_all() {
+ export SETUPTOOLS_SCM_PRETEND_VERSION="${PV}"
+ distutils-r1_python_prepare_all
+}