aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPascal Jäger <pascal.jaeger@leimstift.de>2022-11-26 16:15:37 +0100
committerPascal Jäger <pascal.jaeger@leimstift.de>2022-11-26 16:18:06 +0100
commit2ce474cacfcfcf2e0d3ba724f28c6b5872244f21 (patch)
tree29d4bc341ffc53e2d02644d1b997dee94daba1ba
parentapp-backup/timeshift-22.06.5: revbump, use make instead of emake (diff)
downloadguru-2ce474cacfcfcf2e0d3ba724f28c6b5872244f21.tar.gz
guru-2ce474cacfcfcf2e0d3ba724f28c6b5872244f21.tar.bz2
guru-2ce474cacfcfcf2e0d3ba724f28c6b5872244f21.zip
app-backup/timeshift-21.09.1: revbump, use make instead of emake
- update xdg icon cache after install Bug: https://bugs.gentoo.org/849626 Bug: https://bugs.gentoo.org/849629 Bug: https://bugs.gentoo.org/883157 Signed-off-by: Pascal Jäger <pascal.jaeger@leimstift.de>
-rw-r--r--app-backup/timeshift/timeshift-21.09.1-r2.ebuild (renamed from app-backup/timeshift/timeshift-21.09.1-r1.ebuild)23
1 files changed, 20 insertions, 3 deletions
diff --git a/app-backup/timeshift/timeshift-21.09.1-r1.ebuild b/app-backup/timeshift/timeshift-21.09.1-r2.ebuild
index 97f794686..09ac8c406 100644
--- a/app-backup/timeshift/timeshift-21.09.1-r1.ebuild
+++ b/app-backup/timeshift/timeshift-21.09.1-r2.ebuild
@@ -1,9 +1,8 @@
# Copyright 2019-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-VALA_MIN_API_VERSION="0.44"
-inherit vala xdg
+EAPI=8
+inherit optfeature toolchain-funcs vala xdg
DESCRIPTION="A system restore utility for Linux"
HOMEPAGE="https://github.com/teejee2008/timeshift"
@@ -40,3 +39,21 @@ src_prepare() {
vala_src_prepare
default
}
+
+src_compile() {
+ tc-export CC
+ # can't use emake here, fails to compile because some files getting removed
+ # during compilation, which are missing afterwards.
+ # https://bugs.gentoo.org/883157
+ # Pascal Jäger <pascal.jaeger@leimstift.de> (2022-11-26)
+ make all || die
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ optfeature "btrfs support" sys-fs/btrfs-progs
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+}