aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Smith <matt@offtopica.uk>2021-06-19 22:06:05 +0100
committerMatt Smith <matt@offtopica.uk>2021-06-19 22:06:05 +0100
commit2d13609e67d8887260351ce855fa87374004f103 (patch)
treebd80d003a914cbaaeb7229b893331c1ecdac8af4
parentwww-client/torbrowser-launcher: remove patch from live version (diff)
downloadguru-2d13609e.tar.gz
guru-2d13609e.tar.bz2
guru-2d13609e.zip
dev-scheme/chez: Init at 9.5.4
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Matt Smith <matt@offtopica.uk>
-rw-r--r--dev-scheme/chez/Manifest1
-rw-r--r--dev-scheme/chez/chez-9.5.4.ebuild33
-rw-r--r--dev-scheme/chez/metadata.xml25
3 files changed, 59 insertions, 0 deletions
diff --git a/dev-scheme/chez/Manifest b/dev-scheme/chez/Manifest
new file mode 100644
index 0000000000..25b85f466e
--- /dev/null
+++ b/dev-scheme/chez/Manifest
@@ -0,0 +1 @@
+DIST csv9.5.4.tar.gz 32313134 BLAKE2B ef8ec4e40389cfdc5bd1f631b02b5439f5353e73f95c48ecf1ec813cd6dc651b305cf019bb3e3083907f402b6578c31a10b2490bce32de6fa621f55d850ae168 SHA512 bc377fc5a7355703193849a21fbcd633f35b56f1f898c747fbddedc63ac979c124d966bdd9ed32366bb466881abdf44e03085af16e9795b10975a72c0d0b6123
diff --git a/dev-scheme/chez/chez-9.5.4.ebuild b/dev-scheme/chez/chez-9.5.4.ebuild
new file mode 100644
index 0000000000..435cba4d35
--- /dev/null
+++ b/dev-scheme/chez/chez-9.5.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A programming language based on R6RS"
+HOMEPAGE="https://cisco.github.io/ChezScheme/ https://github.com/cisco/ChezScheme"
+SRC_URI="https://github.com/cisco/ChezScheme/releases/download/v${PV}/csv${PV}.tar.gz"
+
+# Chez Scheme itself is Apache 2.0, but it vendors LZ4 (BSD-2),
+# Nanopass (MIT), stex (MIT), and zlib (ZLIB).
+LICENSE="Apache-2.0 BSD-2 MIT ZLIB"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+S="${WORKDIR}"/csv${PV}
+
+src_configure() {
+ local myconfargs=(
+ --installprefix="${EPREFIX}"/usr
+ --nogzip-man-pages
+ --disable-curses # TODO: ncurses USE flag.
+ --disable-x11 # TODO: X USE flag.
+ )
+
+ ./configure "${myconfargs[@]}" || die
+}
+
+src_install() {
+ emake install TempRoot="${D}"
+ use examples || rm -r "${D}"/usr/lib/csv${PV}/examples || die
+}
diff --git a/dev-scheme/chez/metadata.xml b/dev-scheme/chez/metadata.xml
new file mode 100644
index 0000000000..75836ec561
--- /dev/null
+++ b/dev-scheme/chez/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>matt@offtopica.uk</email>
+ <name>Matt Smith</name>
+ </maintainer>
+ <longdescription lang="en">
+ Chez Scheme is both a programming language and an implementation
+ of that language, with supporting tools and documentation.
+
+ As a superset of the language described in the Revised6 Report on
+ the Algorithmic Language Scheme (R6RS), Chez Scheme supports all
+ standard features of Scheme, including first-class procedures,
+ proper treatment of tail calls, continuations, user-defined
+ records, libraries, exceptions, and hygienic macro expansion.
+
+ Chez Scheme also includes extensive support for interfacing with C
+ and other languages, support for multiple threads possibly running
+ on multiple cores, non-blocking I/O, and many other features.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">cisco/ChezScheme</remote-id>
+ </upstream>
+</pkgmetadata>