aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-10-31 17:57:57 +0100
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-10-31 17:58:20 +0100
commit2d29b0741771b6acecf68f99ba62ee310c1eafd1 (patch)
tree2458dc856f4b588ab2ac747a2bbd6d049ab1ad75
parentapp-mics/doublecmd-bin: 1.0.1 version bump (diff)
downloadguru-2d29b0741771b6acecf68f99ba62ee310c1eafd1.tar.gz
guru-2d29b0741771b6acecf68f99ba62ee310c1eafd1.tar.bz2
guru-2d29b0741771b6acecf68f99ba62ee310c1eafd1.zip
dev-python/os-vif: new version
Closes: https://bugs.gentoo.org/800311 Closes: https://bugs.gentoo.org/800308 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
-rw-r--r--dev-python/os-vif/Manifest2
-rw-r--r--dev-python/os-vif/os-vif-2.6.0.ebuild (renamed from dev-python/os-vif/os-vif-2.2.0.ebuild)28
2 files changed, 20 insertions, 10 deletions
diff --git a/dev-python/os-vif/Manifest b/dev-python/os-vif/Manifest
index 4e52ac328..0d3ae74d1 100644
--- a/dev-python/os-vif/Manifest
+++ b/dev-python/os-vif/Manifest
@@ -1 +1 @@
-DIST os_vif-2.2.0.tar.gz 88781 BLAKE2B 99cb3337cc8b67fc6977e284f2e3370b47ff9346752cbe99fff65fddec80f8dbd0ca4d67527a0afcfb0e35fa8e42084a8e45a0dcb7ba66a1046ff32c752e5702 SHA512 eb06e0fcee7f061670438f81098f69c6d480d5f901c7dc8f0e38f4ed1494701c7711444907abba989d577230fc05d863697b7b813099fe1fb1820b25de677901
+DIST os_vif-2.6.0.tar.gz 96458 BLAKE2B 613d0ef0b17906e6da01d1f31f588a37b2d03dd7ceb287177904159343fc0f80bccf763e000bbb8bef98fc5c69ddc5efebf9ba211418eb136576dfe0ad748471 SHA512 1ad6d00025abeff833c82e22f5ec6ce11176b3073e3dba7bca729433f7c8b77b344919b841aef2beb2aa6e606d7d3f19958b414c1d0ec4dcd89089a7866eff1a
diff --git a/dev-python/os-vif/os-vif-2.2.0.ebuild b/dev-python/os-vif/os-vif-2.6.0.ebuild
index 42cbe950c..dd31c73d4 100644
--- a/dev-python/os-vif/os-vif-2.2.0.ebuild
+++ b/dev-python/os-vif/os-vif-2.6.0.ebuild
@@ -1,28 +1,28 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
PYTHON_COMPAT=( python3_8 )
inherit distutils-r1
DESCRIPTION="OpenStack Cinder brick library for managing local volume attaches"
-HOMEPAGE="https://github.com/openstack/os-vif"
+HOMEPAGE="
+ https://github.com/openstack/os-vif
+ https://opendev.org/openstack/os-vif
+ https://launchpad.net/os-vif
+ https://pypi.org/project/os-vif
+"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/os_vif-${PV}.tar.gz"
S="${WORKDIR}/os_vif-${PV}"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64"
-IUSE=""
-DEPEND="
- >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
- !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
-"
RDEPEND="
>=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
- !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
>=dev-python/netaddr-0.7.18[${PYTHON_USEDEP}]
>=dev-python/oslo-concurrency-3.20.0[${PYTHON_USEDEP}]
>=dev-python/oslo-config-5.1.0[${PYTHON_USEDEP}]
@@ -35,3 +35,13 @@ RDEPEND="
>=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
>=dev-python/debtcollector-1.19.0[${PYTHON_USEDEP}]
"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ test? (
+ >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/ovs-2.9.2[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest