aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2020-04-25 00:03:17 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2020-04-25 02:37:15 +0200
commit2db41d8dd36beba0c565cfabaeb169f8ccb4f355 (patch)
tree7943dcc3b2276e04b0d4e82c046b0c9546d0ca84
parentdev-python/ufoLib2: add unzip dep (diff)
downloadguru-2db41d8dd36beba0c565cfabaeb169f8ccb4f355.tar.gz
guru-2db41d8dd36beba0c565cfabaeb169f8ccb4f355.tar.bz2
guru-2db41d8dd36beba0c565cfabaeb169f8ccb4f355.zip
dev-python/text-unidecode: new package
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
-rw-r--r--dev-python/text-unidecode/Manifest1
-rw-r--r--dev-python/text-unidecode/metadata.xml15
-rw-r--r--dev-python/text-unidecode/text-unidecode-1.3.ebuild33
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/text-unidecode/Manifest b/dev-python/text-unidecode/Manifest
new file mode 100644
index 000000000..7cf837a09
--- /dev/null
+++ b/dev-python/text-unidecode/Manifest
@@ -0,0 +1 @@
+DIST text-unidecode-1.3.tar.gz 76885 BLAKE2B b783963b4fce6588d45d48a498de566c08df83ae62c72caf599648df195eb94b7c02090503590ab8c747af0d210847ddfbf0772289e170361914db20c049828e SHA512 aeaf0e79bd0545ca7a4fe700d5a7dac1d5900841fcfe8a5a568c84ba7d3bee5f75eaac0531f4a01d689a550ac5bc7e1acaeb8132293f220db8387fae2eb6a150
diff --git a/dev-python/text-unidecode/metadata.xml b/dev-python/text-unidecode/metadata.xml
new file mode 100644
index 000000000..3f17f6d77
--- /dev/null
+++ b/dev-python/text-unidecode/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>lssndrbarbieri@gmail.com</email>
+ <name>Alessandro Barbieri</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">text-unidecode</remote-id>
+ <maintainer status="unknown">
+ <email>kmike84@gmail.com</email>
+ <name>Mikhail Korobov</name>
+ </maintainer>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/text-unidecode/text-unidecode-1.3.ebuild b/dev-python/text-unidecode/text-unidecode-1.3.ebuild
new file mode 100644
index 000000000..496d2de44
--- /dev/null
+++ b/dev-python/text-unidecode/text-unidecode-1.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( pypy3 python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="The most basic Text::Unidecode port"
+HOMEPAGE="https://github.com/kmike/text-unidecode"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( Artistic GPL-1 GPL-2+ )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( dev-python/pytest )"
+RDEPEND=""
+
+python_prepare_all() {
+ sed -i '/pytest-runner/d' setup.py
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ distutils_install_for_testing
+ cd "${TEST_DIR}" || die
+ cp "${S}/test_unidecode.py" . || die
+ cp "${S}/setup.cfg" . || die
+ pytest || die "Tests fail with ${EPYTHON}"
+}