aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Freyermuth <o.freyermuth@googlemail.com>2022-12-24 22:24:04 +0100
committerOliver Freyermuth <o.freyermuth@googlemail.com>2022-12-24 22:24:04 +0100
commit2f60169115bada72bbf046a698cc901d8d7384ac (patch)
tree922fcd5ac5a928c1df071d2ae8ade0073f3cb3a6
parentapp-misc/lf: add 28 (diff)
downloadguru-2f60169115bada72bbf046a698cc901d8d7384ac.tar.gz
guru-2f60169115bada72bbf046a698cc901d8d7384ac.tar.bz2
guru-2f60169115bada72bbf046a698cc901d8d7384ac.zip
x11-misc/gromit-mpx: Fix implicit function declaration.
This fixes compilation with -Werror,-Wimplicit-function-declaration. Closes: https://bugs.gentoo.org/888149 Signed-off-by: Oliver Freyermuth <o.freyermuth@googlemail.com>
-rw-r--r--x11-misc/gromit-mpx/files/gromit-mpx-1.4.3-fwd-declare-app_parse_args.patch16
-rw-r--r--x11-misc/gromit-mpx/gromit-mpx-1.4.3.ebuild4
2 files changed, 20 insertions, 0 deletions
diff --git a/x11-misc/gromit-mpx/files/gromit-mpx-1.4.3-fwd-declare-app_parse_args.patch b/x11-misc/gromit-mpx/files/gromit-mpx-1.4.3-fwd-declare-app_parse_args.patch
new file mode 100644
index 000000000..90367cfb4
--- /dev/null
+++ b/x11-misc/gromit-mpx/files/gromit-mpx-1.4.3-fwd-declare-app_parse_args.patch
@@ -0,0 +1,16 @@
+Fixes compilation with -Werror,-Wimplicit-function-declaration.
+
+Bug: https://bugs.gentoo.org/888149
+Bug: https://github.com/bk138/gromit-mpx/pull/173
+
+--- gromit-mpx-1.4.3/src/gromit-mpx.c 2022-09-25 14:43:43.000000000 +0200
++++ gromit-mpx-1.4.3/src/gromit-mpx.c 2022-12-24 18:32:23.629233288 +0100
+@@ -696,7 +696,7 @@
+ }
+
+
+-
++int app_parse_args (int argc, char **argv, GromitData *data);
+
+
+ void setup_main_app (GromitData *data, int argc, char ** argv)
diff --git a/x11-misc/gromit-mpx/gromit-mpx-1.4.3.ebuild b/x11-misc/gromit-mpx/gromit-mpx-1.4.3.ebuild
index 95600ede0..1d64637ab 100644
--- a/x11-misc/gromit-mpx/gromit-mpx-1.4.3.ebuild
+++ b/x11-misc/gromit-mpx/gromit-mpx-1.4.3.ebuild
@@ -27,6 +27,10 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.4.3-fwd-declare-app_parse_args.patch
+)
+
src_prepare () {
cmake_src_prepare
}