aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHuang Rui <vowstar@gmail.com>2022-11-02 15:09:59 +0800
committerHuang Rui <vowstar@gmail.com>2022-11-02 15:10:52 +0800
commit308e7f755a0f7bb81c419b1c15cd4be83cc71874 (patch)
tree395b70187ce0d17b9c066a5030d434d32a3ac676
parentgames-misc/varlpenis: new package, add 3.0.2 (diff)
downloadguru-308e7f75.tar.gz
guru-308e7f75.tar.bz2
guru-308e7f75.zip
dev-libs/unordered_dense: new package, add 2.0.0, 9999
Signed-off-by: Huang Rui <vowstar@gmail.com>
-rw-r--r--dev-libs/unordered_dense/Manifest1
-rw-r--r--dev-libs/unordered_dense/metadata.xml20
-rw-r--r--dev-libs/unordered_dense/unordered_dense-2.0.0.ebuild37
-rw-r--r--dev-libs/unordered_dense/unordered_dense-9999.ebuild37
4 files changed, 95 insertions, 0 deletions
diff --git a/dev-libs/unordered_dense/Manifest b/dev-libs/unordered_dense/Manifest
new file mode 100644
index 000000000..ad9aa17ea
--- /dev/null
+++ b/dev-libs/unordered_dense/Manifest
@@ -0,0 +1 @@
+DIST unordered_dense-2.0.0.tar.gz 307275 BLAKE2B d579740134a8e67e8487c1d6779bc5ea2bf0b3ab70ce60f3b8b68d1fdabc9b45a099e49500b417f21a3fc4c88d2aadbf96afa7b56a8d7d581a0d3f3f6badf61b SHA512 8c7d582abd2142310b50d835ce3cb9a0731a6f7bc6419d01742860cbcb0ade31aad393c93523b8ff82ce456f6cbab5a3d93f91f95c8eb5f7f960fa4793f57d8d
diff --git a/dev-libs/unordered_dense/metadata.xml b/dev-libs/unordered_dense/metadata.xml
new file mode 100644
index 000000000..552890653
--- /dev/null
+++ b/dev-libs/unordered_dense/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>vowstar@gmail.com</email>
+ <name>Huang Rui</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">martinus/unordered_dense</remote-id>
+ </upstream>
+ <longdescription lang="en">
+ A fast and densely stored hashmap and hashset based on robin-hood
+ backward shift deletion.
+ The classes ankerl::unordered_dense::map and
+ ankerl::unordered_dense::set are (almost) drop-in replacements of
+ std::unordered_map and std::unordered_set. While they don't have as
+ strong iterator / reference stability guaranties, they are typically
+ much faster.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-libs/unordered_dense/unordered_dense-2.0.0.ebuild b/dev-libs/unordered_dense/unordered_dense-2.0.0.ebuild
new file mode 100644
index 000000000..05a399fc4
--- /dev/null
+++ b/dev-libs/unordered_dense/unordered_dense-2.0.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+inherit cmake
+
+DESCRIPTION="A fast and densely stored hashmap and hashset"
+HOMEPAGE="https://github.com/martinus/unordered_dense"
+
+if [[ "${PV}" == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/martinus/${PN}.git"
+else
+ SRC_URI="https://github.com/martinus/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+ S="${WORKDIR}/${P}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=""
+
+DEPEND="
+ ${RDEPEND}
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -D CMAKE_INSTALL_LIBDIR="${EPREFIX}/usr/$(get_libdir)"
+ -D BUILD_SHARED_LIBS=ON
+ )
+ cmake_src_configure
+}
diff --git a/dev-libs/unordered_dense/unordered_dense-9999.ebuild b/dev-libs/unordered_dense/unordered_dense-9999.ebuild
new file mode 100644
index 000000000..05a399fc4
--- /dev/null
+++ b/dev-libs/unordered_dense/unordered_dense-9999.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+inherit cmake
+
+DESCRIPTION="A fast and densely stored hashmap and hashset"
+HOMEPAGE="https://github.com/martinus/unordered_dense"
+
+if [[ "${PV}" == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/martinus/${PN}.git"
+else
+ SRC_URI="https://github.com/martinus/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+ S="${WORKDIR}/${P}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=""
+
+DEPEND="
+ ${RDEPEND}
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -D CMAKE_INSTALL_LIBDIR="${EPREFIX}/usr/$(get_libdir)"
+ -D BUILD_SHARED_LIBS=ON
+ )
+ cmake_src_configure
+}