aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbrian gloyer <brian.gloyer@gmail.com>2022-06-30 21:58:28 -0700
committerbrian gloyer <brian.gloyer@gmail.com>2022-06-30 22:03:06 -0700
commit3117dcca185751254eda14174ee84165f1321df5 (patch)
treebd710801f8c6ca17e783e2d1b7566c647b2c2225
parentdev-java/jgraph: add 5.14.0.0_p20180427, drop 5.12.4.2 (diff)
downloadguru-3117dcca.tar.gz
guru-3117dcca.tar.bz2
guru-3117dcca.zip
app-portage/appswipe: icon fix
Closes: https://bugs.gentoo.org/855065 Signed-off-by: brian gloyer <brian.gloyer@gmail.com>
-rw-r--r--app-portage/appswipe/appswipe-1.1.14.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/app-portage/appswipe/appswipe-1.1.14.ebuild b/app-portage/appswipe/appswipe-1.1.14.ebuild
index fe58480659..a4e308c5bc 100644
--- a/app-portage/appswipe/appswipe-1.1.14.ebuild
+++ b/app-portage/appswipe/appswipe-1.1.14.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit desktop qmake-utils
+inherit desktop qmake-utils xdg-utils
DESCRIPTION="Application for browsing your local Portage repository files"
HOMEPAGE="https://github.com/k9spud/appswipe"
@@ -39,3 +39,11 @@ src_install() {
doicon -s scalable "${S}/img/appswipe.svg"
domenu ${PN}.desktop
}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}