aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThibaud CANALE <thican@thican.net>2023-03-08 02:14:38 +0100
committerThibaud CANALE <thican@thican.net>2023-03-15 01:33:02 +0100
commit31a4adc84b7460078b8d2fc83ef43b21dfbeac09 (patch)
tree40cabc33f3e89e375de738d55b3533be1d4ea883
parentapp-crypt/tpm2-openssl: Fix failing test (diff)
downloadguru-31a4adc8.tar.gz
guru-31a4adc8.tar.bz2
guru-31a4adc8.zip
app-crypt/certbot-dns-rfc2136: add 2.3.0, 2.4.0
Signed-off-by: Thibaud CANALE <thican@thican.net>
-rw-r--r--app-crypt/certbot-dns-rfc2136/Manifest2
-rw-r--r--app-crypt/certbot-dns-rfc2136/certbot-dns-rfc2136-2.3.0.ebuild70
-rw-r--r--app-crypt/certbot-dns-rfc2136/certbot-dns-rfc2136-2.4.0.ebuild70
-rw-r--r--app-crypt/certbot-dns-rfc2136/certbot-dns-rfc2136-9999.ebuild4
4 files changed, 144 insertions, 2 deletions
diff --git a/app-crypt/certbot-dns-rfc2136/Manifest b/app-crypt/certbot-dns-rfc2136/Manifest
index 3e3aea56f..b3e248e20 100644
--- a/app-crypt/certbot-dns-rfc2136/Manifest
+++ b/app-crypt/certbot-dns-rfc2136/Manifest
@@ -1,3 +1,5 @@
DIST certbot-2.0.0.gh.tar.gz 1326589 BLAKE2B d1dc7e2c2a807f767d5dd4209b0fe079e18a8859c9a1b1dbdf62f240c123f20d5a63f01c5a92a4463b99f50b343e6956ac9a53c14c576b16bcd46c07f6f775f3 SHA512 c72d428a43d19b105a206931f8fe74e0c68dfc288a2e8667f25b9e292820eccd9ad04a11d9d3c4fcdbcb08cf2adc5f5fad12bd53b8df09dcc77c0a500a30e518
DIST certbot-2.1.0.gh.tar.gz 1327451 BLAKE2B c4694622648427146574aa7c056d5d76dc3c4f6b8487a506d1c4996239f979d89ca26980b2ffbaab975458d0691acaa07a46a75098b6146e6e3c51e6eaa64be0 SHA512 83c3a6abeffb135cebd0d0f4561f3814039962e3b895aaf7bef6570641fccda2da04f1a6110c5e90d6ed3346402cbb3ff543b0a096e8e18f6345edd22da643cc
DIST certbot-2.2.0.gh.tar.gz 1331053 BLAKE2B 4a3e6d8b0b3b7f8537bd6b24234bad7657842ee64865bcef2701e572501640b7a2d49cf4dc62db25cda1039be2d20fb77ac6415cdcb4756fce0f96b5cb7410c6 SHA512 242bfa8e5b60c28b49457403b41421ef782b9f98f325cc423b58283fef410b33691c3ce126188b191c80fcd488fe5d51acfc5ca575c8e7c5b6b08198844bffb7
+DIST certbot-2.3.0.gh.tar.gz 1335613 BLAKE2B af8ff393f92755e8e312f7596fe99abefa35c42cef6fa6688f7f3dd4a310205385fec81366df30d8edfe28d8abd3db447c9e1a3770fe31c3d45c69f04a038660 SHA512 5f52d9b0dd390fc696389a94ff897d803ee062feca50bb66972e197dcd79b0096b337cece2798557c3878903577171fd9afe1f18a4a2131ad7e6a62d0d945ebb
+DIST certbot-2.4.0.gh.tar.gz 1333159 BLAKE2B 534c7d090cc8a2b77b2dd8bd8c407409260c18e7741223a327bb240dac9685b1ca152d4a20bb0ec46d8717f89bd3de6f494019c57afe22a74db69641a3ed209e SHA512 c307c97154935a3a01b468d6e91505caba6073b4c01071c87382bdc08c892094d95d75b047047d3221b7d8018a61ce974c0f4defbfdee00b136af920fd579108
diff --git a/app-crypt/certbot-dns-rfc2136/certbot-dns-rfc2136-2.3.0.ebuild b/app-crypt/certbot-dns-rfc2136/certbot-dns-rfc2136-2.3.0.ebuild
new file mode 100644
index 000000000..dd6f254b6
--- /dev/null
+++ b/app-crypt/certbot-dns-rfc2136/certbot-dns-rfc2136-2.3.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+PARENT_PN="${PN%-dns-rfc2136}"
+PARENT_P="${PARENT_PN}-${PV}"
+
+if [[ "${PV}" == *9999 ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ EGIT_SUBMODULES=()
+ EGIT_CHECKOUT_DIR="${WORKDIR}/${PARENT_P}"
+else
+ SRC_URI="
+ https://github.com/certbot/certbot/archive/v${PV}.tar.gz
+ -> ${PARENT_P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+DESCRIPTION="RFC 2136 DNS Authenticator plugin for Certbot (Let’s Encrypt client)"
+HOMEPAGE="
+ https://github.com/certbot/certbot
+ https://letsencrypt.org/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+S="${WORKDIR}/${PARENT_P}/${PN}"
+
+BDEPEND="
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ >=app-crypt/certbot-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/dnspython-1.15.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+# Same than PATCHES but from repository's root directory,
+# please see function `python_prepare_all` below.
+# Simplier for users IMHO.
+PARENT_PATCHES=(
+)
+
+# Here for patches within "${PN}" subdirectory.
+PATCHES=(
+)
+
+python_prepare_all() {
+ pushd "${WORKDIR}/${PARENT_P}" > /dev/null || die
+ [[ -n "${PARENT_PATCHES[@]}" ]] && eapply "${PARENT_PATCHES[@]}"
+ eapply_user
+ popd > /dev/null || die
+
+ distutils-r1_python_prepare_all
+}
diff --git a/app-crypt/certbot-dns-rfc2136/certbot-dns-rfc2136-2.4.0.ebuild b/app-crypt/certbot-dns-rfc2136/certbot-dns-rfc2136-2.4.0.ebuild
new file mode 100644
index 000000000..dd6f254b6
--- /dev/null
+++ b/app-crypt/certbot-dns-rfc2136/certbot-dns-rfc2136-2.4.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+PARENT_PN="${PN%-dns-rfc2136}"
+PARENT_P="${PARENT_PN}-${PV}"
+
+if [[ "${PV}" == *9999 ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ EGIT_SUBMODULES=()
+ EGIT_CHECKOUT_DIR="${WORKDIR}/${PARENT_P}"
+else
+ SRC_URI="
+ https://github.com/certbot/certbot/archive/v${PV}.tar.gz
+ -> ${PARENT_P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+DESCRIPTION="RFC 2136 DNS Authenticator plugin for Certbot (Let’s Encrypt client)"
+HOMEPAGE="
+ https://github.com/certbot/certbot
+ https://letsencrypt.org/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+S="${WORKDIR}/${PARENT_P}/${PN}"
+
+BDEPEND="
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ >=app-crypt/certbot-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/dnspython-1.15.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+# Same than PATCHES but from repository's root directory,
+# please see function `python_prepare_all` below.
+# Simplier for users IMHO.
+PARENT_PATCHES=(
+)
+
+# Here for patches within "${PN}" subdirectory.
+PATCHES=(
+)
+
+python_prepare_all() {
+ pushd "${WORKDIR}/${PARENT_P}" > /dev/null || die
+ [[ -n "${PARENT_PATCHES[@]}" ]] && eapply "${PARENT_PATCHES[@]}"
+ eapply_user
+ popd > /dev/null || die
+
+ distutils-r1_python_prepare_all
+}
diff --git a/app-crypt/certbot-dns-rfc2136/certbot-dns-rfc2136-9999.ebuild b/app-crypt/certbot-dns-rfc2136/certbot-dns-rfc2136-9999.ebuild
index e784b2ceb..dd6f254b6 100644
--- a/app-crypt/certbot-dns-rfc2136/certbot-dns-rfc2136-9999.ebuild
+++ b/app-crypt/certbot-dns-rfc2136/certbot-dns-rfc2136-9999.ebuild
@@ -37,14 +37,14 @@ SLOT="0"
S="${WORKDIR}/${PARENT_P}/${PN}"
BDEPEND="
- test? ( >=dev-python/pytest-7.2.0[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
"
RDEPEND="
${PYTHON_DEPS}
>=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
>=app-crypt/certbot-${PV}[${PYTHON_USEDEP}]
- >=dev-python/dnspython-2.2.1[${PYTHON_USEDEP}]
+ >=dev-python/dnspython-1.15.0[${PYTHON_USEDEP}]
"
distutils_enable_sphinx docs dev-python/sphinx-rtd-theme