aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Anderson <telans@posteo.de>2021-04-16 20:46:16 +1200
committerTheo Anderson <telans@posteo.de>2021-04-16 20:50:21 +1200
commit347957bcbcbcdea2ea6c364c4766d0423627ed6d (patch)
tree666a7115629b53909baef5da72270749df130fc7
parentapp-editors/typora-bin: add missing deps (diff)
downloadguru-347957bc.tar.gz
guru-347957bc.tar.bz2
guru-347957bc.zip
dev-python/pyinstaller: don't pre-strip binaries (take 2)
even when forcing waf to build bootloaders locally and after removing all references to strip, portage still complains. not sure what's going on here Closes: https://bugs.gentoo.org/783090 Signed-off-by: Theo Anderson <telans@posteo.de>
-rw-r--r--dev-python/pyinstaller/files/pyinstaller-4.2-dont-pre-strip.patch23
-rw-r--r--dev-python/pyinstaller/pyinstaller-4.2.ebuild2
2 files changed, 1 insertions, 24 deletions
diff --git a/dev-python/pyinstaller/files/pyinstaller-4.2-dont-pre-strip.patch b/dev-python/pyinstaller/files/pyinstaller-4.2-dont-pre-strip.patch
deleted file mode 100644
index ec6dcbbd4..000000000
--- a/dev-python/pyinstaller/files/pyinstaller-4.2-dont-pre-strip.patch
+++ /dev/null
@@ -1,23 +0,0 @@
---- a/bootloader/wscript
-+++ b/bootloader/wscript
-@@ -652,11 +652,6 @@ def configure(ctx):
- if ctx.env.DEST_OS == 'linux' and ctx.check_cc(cflags='-Wl,--as-needed'):
- ctx.env.append_value('LINKFLAGS', '-Wl,--as-needed')
-
-- if ctx.env.CC_NAME != 'msvc':
-- # This tool allows reducing the size of executables.
-- ctx.find_program([assoc_programm(ctx, 'strip')], var='STRIP')
-- ctx.load('strip', tooldir='tools')
--
- def windowed(name, baseenv):
- """Setup windowed environment based on `baseenv`."""
- ctx.setenv(name, baseenv) # Inherit from `baseenv`.
-@@ -731,7 +726,7 @@ def build(ctx):
- includes='zlib')
-
- # By default strip final executables to make them smaller.
-- features = 'strip'
-+ features = ''
- if ctx.env.CC_NAME == 'msvc':
- # Do not strip bootloaders when using MSVC.
- features = ''
diff --git a/dev-python/pyinstaller/pyinstaller-4.2.ebuild b/dev-python/pyinstaller/pyinstaller-4.2.ebuild
index 4eeffc3d6..a9be3e283 100644
--- a/dev-python/pyinstaller/pyinstaller-4.2.ebuild
+++ b/dev-python/pyinstaller/pyinstaller-4.2.ebuild
@@ -16,4 +16,4 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64"
-PATCHES=( "${FILESDIR}/${PN}-4.2-dont-pre-strip.patch" )
+QA_PRESTRIPPED="usr/lib/python.*/site-packages/PyInstaller/bootloader/Linux-.*/run.*"