aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-05-30 15:04:48 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-05-30 15:17:12 +0200
commit3480e3ff95d4ac9b91a73382be7fee259b486f09 (patch)
tree6cd726bab1f943420cb73ab378675c66df4cf537
parentdev-python/python-designateclient: enable py3.10 (diff)
downloadguru-3480e3ff.tar.gz
guru-3480e3ff.tar.bz2
guru-3480e3ff.zip
dev-python/fontParts: drop 0.10.4
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
-rw-r--r--dev-python/fontParts/Manifest1
-rw-r--r--dev-python/fontParts/fontParts-0.10.4.ebuild37
2 files changed, 0 insertions, 38 deletions
diff --git a/dev-python/fontParts/Manifest b/dev-python/fontParts/Manifest
index 8d038490ce..2ab0eef0ef 100644
--- a/dev-python/fontParts/Manifest
+++ b/dev-python/fontParts/Manifest
@@ -1,2 +1 @@
-DIST fontParts-0.10.4.tar.gz 428116 BLAKE2B c3f7dcab8f8825a118373d0ba282bbbdf86073c5f0862a6ef04b88b35152370687c625933b41e1bd4da615af0325d971178186e74d2005fd12f85035d36e2979 SHA512 35bf88b80edeef3a52c46e7b8bb991e99ee93bf6a65909b81368a5a514898f7fe60354134200c176761787e8927170c064997a4d16979585d3b8ddf9962f3afe
DIST fontParts-0.10.5.tar.gz 431282 BLAKE2B f0585b0220b35f9b6fc18ace6b517b69fecf87e2d0e1fda7ea5753512851e49b2fd122af628286a638d9c178212602e0ca467b38a94577d11ea3bb117d944a6b SHA512 961507c60de82da516f5cefbb3ca998533751234953c01c28e2ca534d47916e534c1cd6dc95add182e7da10ff57b1a0e0e5ad20fcbe4c385d5f2f58dde0be927
diff --git a/dev-python/fontParts/fontParts-0.10.4.ebuild b/dev-python/fontParts/fontParts-0.10.4.ebuild
deleted file mode 100644
index 3a830bddee..0000000000
--- a/dev-python/fontParts/fontParts-0.10.4.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..9} )
-
-inherit distutils-r1
-
-DESCRIPTION="An API for interacting with the parts of fonts"
-HOMEPAGE="https://github.com/robotools/fontParts"
-SRC_URI="https://github.com/robotools/fontParts/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
-
-KEYWORDS="~amd64 ~x86"
-LICENSE="MIT"
-SLOT="0"
-IUSE="test"
-
-RDEPEND="
- ${PYTHON_DEPS}
- >=dev-python/booleanOperations-0.9.0[${PYTHON_USEDEP}]
- >=dev-python/defcon-0.6.0[${PYTHON_USEDEP}]
- >=dev-python/fontMath-0.4.8[${PYTHON_USEDEP}]
- >=dev-python/fonttools-3.32.0[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}"
-BDEPEND="test? ( dev-python/fontPens[${PYTHON_USEDEP}] )"
-
-RESTRICT="!test? ( test )"
-
-pkg_setup() {
- export SETUPTOOLS_SCM_PRETEND_VERSION="${PV%_*}"
-}
-
-python_test() {
- "${EPYTHON}" Lib/fontParts/fontshell/test.py -v || die "Tests failed with ${EPYTHON}"
-}