aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZamarin Arthur <arthurzam@gmail.com>2021-04-23 19:32:04 +0300
committerZamarin Arthur <arthurzam@gmail.com>2021-04-23 19:32:04 +0300
commit3537c63f2c5fd1ecca3fe14213865a67087661bd (patch)
tree9c6bcd1d674ca0b3c8cf891540ec9f805e79aa4d
parentsys-process/iotop-c: add linux kernel config checks (diff)
downloadguru-3537c63f2c5fd1ecca3fe14213865a67087661bd.tar.gz
guru-3537c63f2c5fd1ecca3fe14213865a67087661bd.tar.bz2
guru-3537c63f2c5fd1ecca3fe14213865a67087661bd.zip
sys-process/iotop-c: fix CC and PKG_CONFIG calls
Closes: https://bugs.gentoo.org/785148 Signed-off-by: Zamarin Arthur <arthurzam@gmail.com>
-rw-r--r--sys-process/iotop-c/iotop-c-1.17-r1.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/sys-process/iotop-c/iotop-c-1.17-r1.ebuild b/sys-process/iotop-c/iotop-c-1.17-r1.ebuild
index ad5cd74c1..d778526f6 100644
--- a/sys-process/iotop-c/iotop-c-1.17-r1.ebuild
+++ b/sys-process/iotop-c/iotop-c-1.17-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit fcaps linux-info
+inherit fcaps linux-info toolchain-funcs
DESCRIPTION="top utility for IO (C port)"
HOMEPAGE="https://github.com/Tomas-M/iotop"
@@ -27,7 +27,7 @@ FILECAPS=(
)
src_compile() {
- emake V=1
+ emake V=1 CC="$(tc-getCC)" PKG_CONFIG="$(tc-getPKG_CONFIG)"
}
src_install() {