aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2022-05-31 12:06:37 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2022-05-31 12:26:49 +0500
commit35c0594240b0d72c32ffc5ef9bf8921820b67bd3 (patch)
treeb7de5f04473b7981e9ab6c81202e0ecd44585b3d
parentdev-python/statmake: drop 0.4.1 (diff)
downloadguru-35c05942.tar.gz
guru-35c05942.tar.bz2
guru-35c05942.zip
dev-python/vttlib: update EAPI 7 -> 8
Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
-rw-r--r--dev-python/vttlib/vttlib-0.11.0.ebuild22
1 files changed, 9 insertions, 13 deletions
diff --git a/dev-python/vttlib/vttlib-0.11.0.ebuild b/dev-python/vttlib/vttlib-0.11.0.ebuild
index 42e9ca0ea..fda92c59c 100644
--- a/dev-python/vttlib/vttlib-0.11.0.ebuild
+++ b/dev-python/vttlib/vttlib-0.11.0.ebuild
@@ -1,43 +1,39 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="7"
+EAPI=8
-DISTUTILS_USE_SETUPTOOLS=pyproject.toml
-MYPN="vttLib"
-MYPV="${PV/_p/.post}"
-MYP="${MYPN}-${MYPV}"
+DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{8..9} )
-
inherit distutils-r1
+MY_PN="vttLib"
+MY_PV="${PV/_p/.post}"
+MY_P="${MY_PN}-${MY_PV}"
DESCRIPTION="Dump, merge and compile Visual TrueType data in UFO3 with FontTools"
HOMEPAGE="
https://github.com/daltonmaag/vttLib
https://pypi.org/project/vttlib/
"
-SRC_URI="mirror://pypi/${MYP:0:1}/${MYPN}/${MYP}.zip"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.zip"
+S="${WORKDIR}/${MY_P}"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
-#install_requires
RDEPEND="
>=dev-python/fonttools-4.10.2[${PYTHON_USEDEP}]
>=dev-python/pyparsing-2.4.7[${PYTHON_USEDEP}]
>=dev-python/ufoLib2-0.7.1[${PYTHON_USEDEP}]
"
-#setup_requires
-DEPEND="
- ${RDEPEND}
+BDEPEND="
+ app-arch/unzip
dev-python/setuptools_scm[${PYTHON_USEDEP}]
dev-python/wheel[${PYTHON_USEDEP}]
test? (
>=dev-python/ufo2ft-2.14.0[${PYTHON_USEDEP}]
)
"
-BDEPEND="app-arch/unzip"
-S="${WORKDIR}/${MYP}"
distutils_enable_tests pytest