aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2023-02-27 19:56:20 +0200
committerViorel Munteanu <ceamac@gentoo.org>2023-02-27 19:56:20 +0200
commit35d462a3fedda7b4966799067be5853dfbb6bea0 (patch)
tree289ebeb4ad01d38195769f304cc35c1d86f9e5ed
parentnet-misc/maestral: drop 1.7.0 (diff)
downloadguru-35d462a3.tar.gz
guru-35d462a3.tar.bz2
guru-35d462a3.zip
net-misc/maestral-qt: add 1.7.1
Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
-rw-r--r--net-misc/maestral-qt/Manifest1
-rw-r--r--net-misc/maestral-qt/maestral-qt-1.7.1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/net-misc/maestral-qt/Manifest b/net-misc/maestral-qt/Manifest
index 3db4752c4..6254d2e38 100644
--- a/net-misc/maestral-qt/Manifest
+++ b/net-misc/maestral-qt/Manifest
@@ -1,2 +1,3 @@
DIST maestral-qt-1.5.3.gh.tar.gz 1209467 BLAKE2B d810df1f7e21938b81565afb16049e385c5de1e295d64feeaa317966e139ddc76542a747db71ae76dc1c82a11ec7e266b69968cefa2839878941def4af7711f8 SHA512 fbc8723d6751e31504529a62f00f7becd4531d8613559edde2a4725bc0d5ac783e6c817814059489bead87923135462a871cdffd0f8d1f0f06481df20efde4f5
DIST maestral-qt-1.7.0.gh.tar.gz 1219480 BLAKE2B fac52c52360daacbed0ec0112c9197b72b4ee3865a294b1a29298318fb62c1518dd001b06310cbd771f28b10b60d4fddbd395e93067ec0aaa03b9ebb77baf589 SHA512 a9b31e6a69f0b2bb35a2b8bf3eb3c172b6ba36371eb7d2255bb683a7edfc38b57e9dd802f422f8ad56865e6817259deb05e7be1d95dd06c744c8a6919bc07ea5
+DIST maestral-qt-1.7.1.gh.tar.gz 1219489 BLAKE2B 0d3dbdd81afaedfce127d5825b77aae8e7c9eae764a8a57c668277d92b0051fc684b477936d1b918b57febe98323aedbc115708501586bdcec821059e26ae866 SHA512 a607fa3d3071081075e4101acea1cb54286015666fbc6c7b48c302d1039e24cf2ca1183f5389a6d9dcb8003cb879446210eeccbbdd90dbfaea1aae1282b1943b
diff --git a/net-misc/maestral-qt/maestral-qt-1.7.1.ebuild b/net-misc/maestral-qt/maestral-qt-1.7.1.ebuild
new file mode 100644
index 000000000..6ee74e197
--- /dev/null
+++ b/net-misc/maestral-qt/maestral-qt-1.7.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit desktop distutils-r1
+
+MY_PV=${PV/_rc/.dev}
+DESCRIPTION="Maestral is an open-source Dropbox client written in Python"
+HOMEPAGE="https://maestral.app"
+SRC_URI="https://github.com/samschott/${PN}/archive/refs/tags/v${MY_PV}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}"/${PN}-${MY_PV}
+
+LICENSE="MIT"
+SLOT="0"
+if [[ ${PV} != *_rc* ]]; then
+ KEYWORDS="~amd64"
+fi
+
+RDEPEND="
+ >=dev-python/click-8.0.2[${PYTHON_USEDEP}]
+ dev-python/markdown2[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/PyQt6[widgets,gui,svg,${PYTHON_USEDEP}]
+ =net-misc/maestral-${PV%_rc*}*[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/build[${PYTHON_USEDEP}]
+"
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ domenu src/maestral_qt/resources/maestral.desktop
+}