aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRalph Seichter <gentoo@seichter.de>2019-04-08 19:11:50 +0200
committerRalph Seichter <gentoo@seichter.de>2019-04-08 19:11:50 +0200
commit37a6aebb0ad5e955cb062ef3a028ea4031864ba9 (patch)
treeb672a80079f32c3603d6e24c6c9554184a0582a5
parentInitialize the repository (diff)
downloadguru-37a6aebb.tar.gz
guru-37a6aebb.tar.bz2
guru-37a6aebb.zip
dev-python/pymilter: Interface to sendmail milter API
Python extension module to enable python scripts to attach to Sendmail's libmilter API (which is also used by Postfix), enabling filtering of messages as they arrive. Signed-off-by: Ralph Seichter <gentoo@seichter.de> Package-Manager: Portage-2.3.62, Repoman-2.3.11
-rw-r--r--dev-python/pymilter/Manifest1
-rw-r--r--dev-python/pymilter/metadata.xml17
-rw-r--r--dev-python/pymilter/pymilter-1.0.3.ebuild22
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/pymilter/Manifest b/dev-python/pymilter/Manifest
new file mode 100644
index 000000000..af556a1cf
--- /dev/null
+++ b/dev-python/pymilter/Manifest
@@ -0,0 +1 @@
+DIST pymilter-1.0.3.tar.gz 1024602 BLAKE2B bd1c29b1e56d3be6f6d491ffd9f38ed684cf5ead2174f4ac2c31c29d32a82f350af180de8e8c21f90b10c3f7b7251382a618ca86346a57a93a48f6adfc0be33e SHA512 a015fb8fb088fd7664aba63df72802a61961cd87bcfd3713c0e11d09ff4dcdfd6f50eca14f6d8ef81b2a70887b3b4f43fbd74b80119f21a0c3737b90320c6cf4
diff --git a/dev-python/pymilter/metadata.xml b/dev-python/pymilter/metadata.xml
new file mode 100644
index 000000000..4c8c4ec61
--- /dev/null
+++ b/dev-python/pymilter/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo@seichter.de</email>
+ <name>Ralph Seichter</name>
+ </maintainer>
+ <longdescription>
+ A python extension module to enable python scripts to attach
+ to sendmail’s libmilter functionality. Additional python
+ modules provide for navigating and modifying MIME parts, and
+ sending DSNs or doing CBVs.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">sdgathman/pymilter</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pymilter/pymilter-1.0.3.ebuild b/dev-python/pymilter/pymilter-1.0.3.ebuild
new file mode 100644
index 000000000..9bc7d8423
--- /dev/null
+++ b/dev-python/pymilter/pymilter-1.0.3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface to sendmail milter API"
+HOMEPAGE="https://github.com/sdgathman/pymilter"
+SRC_URI="https://github.com/sdgathman/${PN}/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+S="${WORKDIR}/${PN}-${P}"
+
+python_test() {
+ "${EPYTHON}" -m unittest discover -v
+}