aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-06-29 04:43:06 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-06-29 04:43:47 +0200
commit395ac836e51ff34dfb964468e8d11c2b739d0a99 (patch)
treeb840c4f00eca4a7a0ed6580f4aace54067c78a29
parentdev-python/font-v: initial import (diff)
downloadguru-395ac836e51ff34dfb964468e8d11c2b739d0a99.tar.gz
guru-395ac836e51ff34dfb964468e8d11c2b739d0a99.tar.bz2
guru-395ac836e51ff34dfb964468e8d11c2b739d0a99.zip
dev-python/pip-api: initial import
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
-rw-r--r--dev-python/pip-api/Manifest1
-rw-r--r--dev-python/pip-api/metadata.xml13
-rw-r--r--dev-python/pip-api/pip-api-0.0.14.ebuild37
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/pip-api/Manifest b/dev-python/pip-api/Manifest
new file mode 100644
index 0000000000..e42fe1f30b
--- /dev/null
+++ b/dev-python/pip-api/Manifest
@@ -0,0 +1 @@
+DIST pip-api-0.0.14.tar.gz 112646 BLAKE2B 8bfe738b6c1aee91d407b568c7cc335271f1b739e6db49374248342a4325853dea6650c32384bf89afd95b20f09d361b5edb3b0ecae100fdc3a6855ba010ec24 SHA512 d3802b8728b814dae9551cc12612eb10a8de061cd64ac40647513d083c45f4bee218b1d2ba772c4c4df05275c4dc8e935e8e69c2e2cf8c6420e6c1158c768c78
diff --git a/dev-python/pip-api/metadata.xml b/dev-python/pip-api/metadata.xml
new file mode 100644
index 0000000000..a654b83351
--- /dev/null
+++ b/dev-python/pip-api/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>lssndrbarbieri@gmail.com</email>
+ <name>Alessandro Barbieri</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/di/pip-api/issues</bugs-to>
+ <remote-id type="github">di/pip-api</remote-id>
+ <remote-id type="pypi">pip-api</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pip-api/pip-api-0.0.14.ebuild b/dev-python/pip-api/pip-api-0.0.14.ebuild
new file mode 100644
index 0000000000..347170ee57
--- /dev/null
+++ b/dev-python/pip-api/pip-api-0.0.14.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_SETUPTOOLS="pyproject.toml"
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="An unofficial, importable pip API"
+HOMEPAGE="https://github.com/di/pip-api"
+SRC_URI="https://github.com/di/pip-api/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ dev-python/pip[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pretend[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-20[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ #https://github.com/di/pip-api/issues/81
+ epytest -vv \
+ --deselect tests/test_installed_distributions.py::test_installed_distributions \
+ --deselect tests/test_tests.py::test_isolation[True] \
+ --deselect tests/test_tests.py::test_isolation[False] \
+ --deselect tests/test_tests.py::test_all_the_right_pips \
+ || die
+}