aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-10-04 00:16:09 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-10-04 00:16:39 +0200
commit3b1a40512e8cb9b3f381ee7dc98310553f54049a (patch)
treeccededc9ed655b4e0bb282df35d1e503d3d993b8
parentdev-python/glyphsLib: EAPI bump (diff)
downloadguru-3b1a4051.tar.gz
guru-3b1a4051.tar.bz2
guru-3b1a4051.zip
dev-python/autoflake: EAPI 8
Closes: https://bugs.gentoo.org/816114 Package-Manager: Portage-3.0.26, Repoman-3.0.3 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
-rw-r--r--dev-python/autoflake/autoflake-1.4-r1.ebuild (renamed from dev-python/autoflake/autoflake-1.4.ebuild)10
1 files changed, 5 insertions, 5 deletions
diff --git a/dev-python/autoflake/autoflake-1.4.ebuild b/dev-python/autoflake/autoflake-1.4-r1.ebuild
index d2b5ae13f1..370d5864ad 100644
--- a/dev-python/autoflake/autoflake-1.4.ebuild
+++ b/dev-python/autoflake/autoflake-1.4-r1.ebuild
@@ -1,10 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="7"
+EAPI=8
-PYTHON_COMPAT=( python3_{7,8} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
inherit distutils-r1
@@ -19,11 +18,12 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
-RESTRICT="!test? ( test )"
DEPEND=">=dev-python/pyflakes-1.1.0[${PYTHON_USEDEP}]"
RDEPEND="${DEPEND}"
+RESTRICT="!test? ( test )"
+
python_test() {
"${EPYTHON}" test_autoflake.py || die
}