aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Torokhov <torokhov-s-a@yandex.ru>2022-12-22 04:09:05 +0300
committerSergey Torokhov <torokhov-s-a@yandex.ru>2022-12-22 04:09:05 +0300
commit3b8d080ae6a76fcf463a77a145e0b03b6eceb7a4 (patch)
tree088be95bf7d60b42e238afbe7b597c2a1022e6e7
parentdev-libs/m_cli2: fix compler setup flag typo (diff)
downloadguru-3b8d080ae6a76fcf463a77a145e0b03b6eceb7a4.tar.gz
guru-3b8d080ae6a76fcf463a77a145e0b03b6eceb7a4.tar.bz2
guru-3b8d080ae6a76fcf463a77a145e0b03b6eceb7a4.zip
dev-util/fpm: call 'die' if fail; add '--verbose' for detailed build.log
Closes: https://bugs.gentoo.org/887633 Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru>
-rw-r--r--dev-util/fpm/fpm-0.7.0-r1.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/dev-util/fpm/fpm-0.7.0-r1.ebuild b/dev-util/fpm/fpm-0.7.0-r1.ebuild
index de85b17db..7a3699cfb 100644
--- a/dev-util/fpm/fpm-0.7.0-r1.ebuild
+++ b/dev-util/fpm/fpm-0.7.0-r1.ebuild
@@ -88,10 +88,10 @@ src_compile() {
"$(tc-getFC)" -J "${BSDIR}" -o "${BSDIR}"/fpm "${BSDIR}/${P}.F90" || die
# Use the bootstrap binary to build the feature complete fpm version
- "${BSDIR}"/fpm build --compiler "$(tc-getFC)" --flag "${FCFLAGS} ${OMPFLAG} -I/usr/include/toml-f -I/usr/include/m_cli2" \
+ "${BSDIR}"/fpm build --verbose --compiler "$(tc-getFC)" --flag "${FCFLAGS} ${OMPFLAG} -I/usr/include/toml-f -I/usr/include/m_cli2" \
--c-compiler "$(tc-getCC)" --c-flag "${CFLAGS}" \
--cxx-compiler "$(tc-getCXX)" --cxx-flag "${CXXFLAGS}" \
- --archiver="$(tc-getAR)" --link-flag "${LDFLAGS}"
+ --archiver "$(tc-getAR)" --link-flag "${LDFLAGS}" || die
if use doc ; then
einfo "Build API documentation:"
@@ -100,10 +100,10 @@ src_compile() {
}
src_test() {
- "${BSDIR}"/fpm test --compiler "$(tc-getFC)" --flag "${FCFLAGS} ${OMPFLAG} -I/usr/include/toml-f -I/usr/include/m_cli2" \
+ "${BSDIR}"/fpm test --verbose --compiler "$(tc-getFC)" --flag "${FCFLAGS} ${OMPFLAG} -I/usr/include/toml-f -I/usr/include/m_cli2" \
--c-compiler "$(tc-getCC)" --c-flag "${CFLAGS}" \
--cxx-compiler "$(tc-getCXX)" --cxx-flag "${CXXFLAGS}" \
- --archiver="$(tc-getAR)" --link-flag "${LDFLAGS}"
+ --archiver="$(tc-getAR)" --link-flag "${LDFLAGS}" || die
}
src_install() {
@@ -112,7 +112,7 @@ src_install() {
--compiler "$(tc-getFC)" --flag "${FCFLAGS} ${OMPFLAG} -I/usr/include/toml-f -I/usr/include/m_cli2" \
--c-compiler "$(tc-getCC)" --c-flag "${CFLAGS}" \
--cxx-compiler "$(tc-getCXX)" --cxx-flag "${CXXFLAGS}" \
- --archiver="$(tc-getAR)" --link-flag "${LDFLAGS}"
+ --archiver="$(tc-getAR)" --link-flag "${LDFLAGS}" || die
use doc && HTML_DOCS=( "${S}"/fpm-doc/. )
einstalldocs