aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-08-31 09:44:58 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-08-31 09:44:58 +0200
commit3d11be9747d62445cf9c0c81dedf6fcd0a0f4b90 (patch)
tree2b68f399cc14650ad5713b853938cfffde7ea812
parentgames-misc/cbonsai: add 1.3.1, drop 1.2.1 (diff)
downloadguru-3d11be9747d62445cf9c0c81dedf6fcd0a0f4b90.tar.gz
guru-3d11be9747d62445cf9c0c81dedf6fcd0a0f4b90.tar.bz2
guru-3d11be9747d62445cf9c0c81dedf6fcd0a0f4b90.zip
sys-cluster/wxparaver: do not double install some doc, wxwidgets eclass
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
-rw-r--r--sys-cluster/wxparaver/wxparaver-4.9.0-r1.ebuild (renamed from sys-cluster/wxparaver/wxparaver-4.9.0.ebuild)13
1 files changed, 8 insertions, 5 deletions
diff --git a/sys-cluster/wxparaver/wxparaver-4.9.0.ebuild b/sys-cluster/wxparaver/wxparaver-4.9.0-r1.ebuild
index ba10c93a5..26191463a 100644
--- a/sys-cluster/wxparaver/wxparaver-4.9.0.ebuild
+++ b/sys-cluster/wxparaver/wxparaver-4.9.0-r1.ebuild
@@ -7,8 +7,9 @@ DOCS_AUTODOC=0
DOCS_BUILDER="sphinx"
DOCS_DIR="docs/wxparaver_help_contents/sphinx/2.paraver_toolset/source"
PYTHON_COMPAT=( python3_{8..10} pypy3 )
+WX_GTK_VER="3.0-gtk3"
-inherit autotools python-any-r1 docs
+inherit autotools python-any-r1 docs wxwidgets
DESCRIPTION="paraver gui"
HOMEPAGE="
@@ -26,7 +27,6 @@ RDEPEND="
dev-libs/boost:=
dev-libs/openssl
sys-cluster/paraver-kernel
- x11-libs/wxGTK
extrae? ( sys-cluster/extrae )
"
@@ -46,6 +46,8 @@ src_prepare() {
}
src_configure() {
+ setup-wxwidgets
+
local myconf=(
--disable-old-pcfparser
--with-boost="${EPREFIX}/usr"
@@ -73,7 +75,6 @@ src_compile() {
}
src_install() {
- default
# only a part of the docs can be built from source
if use doc; then
# remove a part of the prebuilt docs
@@ -89,8 +90,10 @@ src_install() {
# override eclass variable
unset HTML_DOCS
HTML_DOCS=( docs/wxparaver_help_contents/install/html/. )
- einstalldocs
+
+ default
+
rm -r "${ED}/usr/share/doc/wxparaver_help_contents" || die
chrpath -d "${ED}/usr/bin/wxparaver.bin" || die
- find "${ED}" -name '*.la' -delete || die
+# find "${ED}" -name '*.la' -delete || die
}