aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-05-30 14:03:13 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-05-30 14:09:10 +0200
commit3f0dbc8eb964c87bff1a44eaebdf904a2bfab6d2 (patch)
tree6add0bcdc4036424d1a34ef73b8dc8eaeb69c886
parentdev-python/rstr: add 3.2.0 (diff)
downloadguru-3f0dbc8e.tar.gz
guru-3f0dbc8e.tar.bz2
guru-3f0dbc8e.zip
dev-python/font-v: update SRC_URI
Closes: https://bugs.gentoo.org/848453 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
-rw-r--r--dev-python/font-v/Manifest3
-rw-r--r--dev-python/font-v/font-v-1.0.5.ebuild39
-rw-r--r--dev-python/font-v/font-v-2.1.0.ebuild10
3 files changed, 7 insertions, 45 deletions
diff --git a/dev-python/font-v/Manifest b/dev-python/font-v/Manifest
index 3fea12de96..cad3730c18 100644
--- a/dev-python/font-v/Manifest
+++ b/dev-python/font-v/Manifest
@@ -1,2 +1 @@
-DIST font-v-1.0.5.tar.gz 4270200 BLAKE2B b94c4e0bff4c07efd50803068e0fc061c910b24f8ed2e70ae1b92d06d69db9d707b6665fdc2179eb80ae814c3b2ad913f58b1c5d4a7b9f81b40269cbb505cfb7 SHA512 070415a72deb8a35804ee548f745edf399fe01ae279ea9ca88f0d1231af77a37f38456726db73e8df26d324bd8e0159b2978a668984d9f8cc24794e2a045cb73
-DIST font-v-2.1.0.tar.gz 4268916 BLAKE2B 596673c62cd29d8428f97d6c6e7cbd9591e9f4f94cc719ee438f59bfeaa81adae4dc2ebb04464cfa42ec4ff71019cf658acbfe05d748f6b98383484d1aaaba4e SHA512 a619971b32828eb026499a8fed67e2c8eca063d1a868be7586f4b8b2802ede5740bef009bf8f4e9891793bf78239d1c0329ebc3bc96cecef59666fe9635ce978
+DIST font-v-2.1.0.gh.tar.gz 4268916 BLAKE2B 596673c62cd29d8428f97d6c6e7cbd9591e9f4f94cc719ee438f59bfeaa81adae4dc2ebb04464cfa42ec4ff71019cf658acbfe05d748f6b98383484d1aaaba4e SHA512 a619971b32828eb026499a8fed67e2c8eca063d1a868be7586f4b8b2802ede5740bef009bf8f4e9891793bf78239d1c0329ebc3bc96cecef59666fe9635ce978
diff --git a/dev-python/font-v/font-v-1.0.5.ebuild b/dev-python/font-v/font-v-1.0.5.ebuild
deleted file mode 100644
index 7f89b12adb..0000000000
--- a/dev-python/font-v/font-v-1.0.5.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..9} )
-
-inherit distutils-r1
-
-SRC_URI="https://github.com/source-foundry/font-v/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-KEYWORDS="~amd64 ~x86"
-DESCRIPTION="Font version string reporting and modification library"
-HOMEPAGE="https://github.com/source-foundry/font-v"
-LICENSE="MIT"
-SLOT="0"
-
-RDEPEND="
- >=dev-python/fonttools-4.17[${PYTHON_USEDEP}]
- >=dev-python/GitPython-3.1.11[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}"
-BDEPEND="test? ( dev-vcs/git )"
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs dev-python/sphinx_rtd_theme
-
-python_test() {
- #it want a git repo
- git init || die
- git config --global user.email "you@example.com" || die
- git config --global user.name "Your Name" || die
- git add . || die
- git commit -m 'init' || die
-
- #pure madness
- #https://github.com/source-foundry/font-v/blob/e6746e4a045c99e56af661918c96259b1f444ed4/tests/test_utilities.py#L34
- sed -e "s|\"font-v\"|\"${PWD##*/}\"|g" -i "tests/test_utilities.py" || die
- epytest -vv
-}
diff --git a/dev-python/font-v/font-v-2.1.0.ebuild b/dev-python/font-v/font-v-2.1.0.ebuild
index c53a816efb..6d6372a91d 100644
--- a/dev-python/font-v/font-v-2.1.0.ebuild
+++ b/dev-python/font-v/font-v-2.1.0.ebuild
@@ -9,7 +9,8 @@ inherit distutils-r1
DESCRIPTION="Font version string reporting and modification library"
HOMEPAGE="https://github.com/source-foundry/font-v"
-SRC_URI="https://github.com/source-foundry/font-v/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://github.com/source-foundry/font-v/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
KEYWORDS="~amd64"
LICENSE="MIT"
SLOT="0"
@@ -21,10 +22,10 @@ RDEPEND="
DEPEND="${RDEPEND}"
BDEPEND="test? ( dev-vcs/git )"
-distutils_enable_tests pytest
+distutils_enable_tests --install pytest
distutils_enable_sphinx docs dev-python/sphinx_rtd_theme
-python_test() {
+src_test() {
#it want a git repo
git init || die
git config --global user.email "you@example.com" || die
@@ -35,5 +36,6 @@ python_test() {
#pure madness
#https://github.com/source-foundry/font-v/blob/e6746e4a045c99e56af661918c96259b1f444ed4/tests/test_utilities.py#L34
sed -e "s|\"font-v\"|\"${PWD##*/}\"|g" -i "tests/test_utilities.py" || die
- epytest -vv
+
+ python_foreach_impl python_test
}