aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZamarin Arthur <arthurzam@gmail.com>2020-08-28 07:56:09 +0300
committerZamarin Arthur <arthurzam@gmail.com>2020-08-28 07:56:09 +0300
commit40211fec30c655db9a1799026c50b3896ef7e601 (patch)
tree93ee5535f60dca3bfee0d3f7cd410652d8c5a835
parentapp-misc/liquidctl: remove a commented out variable (diff)
downloadguru-40211fec.tar.gz
guru-40211fec.tar.bz2
guru-40211fec.zip
sys-process/iotop-c: v1.9 bump
- after long hibernation, the project is active again - fix ncursesw direct linking, use pkg-config for libs - fix license to GPL-2+ Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Zamarin Arthur <arthurzam@gmail.com>
-rw-r--r--sys-process/iotop-c/Manifest1
-rw-r--r--sys-process/iotop-c/iotop-c-1.9.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/sys-process/iotop-c/Manifest b/sys-process/iotop-c/Manifest
index e6c55cc05..0610756c0 100644
--- a/sys-process/iotop-c/Manifest
+++ b/sys-process/iotop-c/Manifest
@@ -1 +1,2 @@
DIST iotop-c-0_pre20140824.tar.gz 16154 BLAKE2B ccd5a1d0901ce7d6c554f9b4a2102e7eab9f9bb456f7f2289b0c7b158c8f220339bc018aeb9295f89b717a711b69cb7f1c144d0c84dce093309e6897ac22a67d SHA512 3dac84abff82f1ec6c14a0dae14c11a2260ebe0a6ec112cda06ecfe2cf8535536c92f432fc03cc2baee6b7326eb4dda4fc2fe08a15c41a78641822daea5726d0
+DIST iotop-c-1.9.tar.gz 28680 BLAKE2B 7e30ca3cec2694afeb2bead7f97eb7ee0dcb3066cf4d1643771b04b724789b9b09836998f6f693bc0a3332b4bb06fb36c46c6ae9b37f0b8088c212136d5bd9f3 SHA512 99a1b9bcae13dbcead1e1c9df8618164be0f9c81e7220d2d4b1e0b8d1528b6a4f6845763a6c04a38510a4174bcaf21abb216f582f49729820cd579e0ca2856f9
diff --git a/sys-process/iotop-c/iotop-c-1.9.ebuild b/sys-process/iotop-c/iotop-c-1.9.ebuild
new file mode 100644
index 000000000..7fef5de54
--- /dev/null
+++ b/sys-process/iotop-c/iotop-c-1.9.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="top utility for IO (C port)"
+HOMEPAGE="https://github.com/Tomas-M/iotop"
+SRC_URI="https://github.com/Tomas-M/iotop/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="sys-libs/ncurses:=
+ !sys-process/iotop"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}/iotop-${PV}"
+
+src_prepare() {
+ default
+ sed -i Makefile -e "s/-lncursesw/$(pkg-config --libs ncursesw)/"
+}
+
+src_install() {
+ dobin iotop
+ dodoc README.md
+}