aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-03-09 15:13:38 +0100
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-03-09 15:43:39 +0100
commit40a73234126cc0715e6f1dc792ddee92e3ea034d (patch)
tree9b8d2bf316662fd08aed6191920b6dbbec158f51
parentdev-python/sphinx-autodoc-typehints: depend on sphinx (diff)
downloadguru-40a73234126cc0715e6f1dc792ddee92e3ea034d.tar.gz
guru-40a73234126cc0715e6f1dc792ddee92e3ea034d.tar.bz2
guru-40a73234126cc0715e6f1dc792ddee92e3ea034d.zip
dev-python/websockets: An implementation of the WebSocket Protocol
Package-Manager: Portage-2.3.93, Repoman-2.3.20 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
-rw-r--r--dev-python/websockets/Manifest1
-rw-r--r--dev-python/websockets/metadata.xml9
-rw-r--r--dev-python/websockets/websockets-8.1.ebuild29
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/websockets/Manifest b/dev-python/websockets/Manifest
new file mode 100644
index 000000000..a83e73473
--- /dev/null
+++ b/dev-python/websockets/Manifest
@@ -0,0 +1 @@
+DIST websockets-8.1.tar.gz 156472 BLAKE2B 6cb5eec8276f7ef7172048eba6157560f42cec28acacc1a0a2f426ea1cab9a04029ebb1f8285b1aa2862c30aac8f2af81ef85d4dba8e53e267b665b718e01d5a SHA512 d245702574cf513da54bfc0ca10768558cd4e5017ecf8cb647f4b9176561192a3ace64edfc5c6f735664bf1b6136aa0bb9828114478f92d2c051e3109a218c12
diff --git a/dev-python/websockets/metadata.xml b/dev-python/websockets/metadata.xml
new file mode 100644
index 000000000..628ab2017
--- /dev/null
+++ b/dev-python/websockets/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>andrewammerlaan@riseup.net</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/websockets/websockets-8.1.ebuild b/dev-python/websockets/websockets-8.1.ebuild
new file mode 100644
index 000000000..e6b3c0c7a
--- /dev/null
+++ b/dev-python/websockets/websockets-8.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="An implementation of the WebSocket Protocol (RFC 6455 & 7692)"
+HOMEPAGE="https://github.com/aaugustin/websockets https://pypi.org/project/websockets/"
+SRC_URI="https://github.com/aaugustin/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+python_prepare_all() {
+ # these tests fail, proabably because of
+ # a permission error (no internet)
+ rm tests/test_client_server.py || die
+ rm tests/test_protocol.py || die
+ rm tests/test_auth.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+distutils_enable_tests nose
+distutils_enable_sphinx docs dev-python/sphinx-autodoc-typehints dev-python/sphinxcontrib-spelling dev-python/sphinxcontrib-trio