aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJian Lin <jlin.gentoo@outlook.com>2021-03-02 01:53:45 +0800
committerJian Lin <jlin.gentoo@outlook.com>2021-03-02 01:53:45 +0800
commit40db11f9ff1bc428f289a0a1f6c6f47964c070be (patch)
tree6c88a4aaaea20ca15dc18bd0e64bbc2aa4435c40
parentsys-auth/mrsh: make systemd units not executable (diff)
downloadguru-40db11f9.tar.gz
guru-40db11f9.tar.bz2
guru-40db11f9.zip
media-video/qliveplayer: bump to 3.22.0
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Jian Lin <jlin.gentoo@outlook.com>
-rw-r--r--media-video/qliveplayer/Manifest1
-rw-r--r--media-video/qliveplayer/qliveplayer-3.22.0.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/media-video/qliveplayer/Manifest b/media-video/qliveplayer/Manifest
index 4618de8a7..b25f8c1a4 100644
--- a/media-video/qliveplayer/Manifest
+++ b/media-video/qliveplayer/Manifest
@@ -1,2 +1,3 @@
DIST QLivePlayer-3.21.0.tar.gz 639005 BLAKE2B 254257cbab62b2578be5a2980c95b982b2da9223756a1efaf3098df1a313d4a252aac70bc032bc13f4e6e330e67d3525a6615d61cec494eab3d666b0ccfc3208 SHA512 755d975b37488979c257ecb8473a3702ee20859d1e1c10c42a7077b84e6b9a890dfb5af442c7a4a30c73bf2a088671ec14c1a4a95c849a724cabf88e6a407ec3
DIST QLivePlayer-3.21.1.tar.gz 639098 BLAKE2B 956edafc652d5124ea14357a8015450c6678d1fa46b9701b5e65e23ca824bcc4e2b2598ff9c5441210afaa32c21c21affb432b323b452053fa5a548816765c56 SHA512 8aca7a62ff4839ff0640b3d982fa6f498996add39d6ed7e4904db2530347c35a56c524cb3c75c85d3de7c635142ff1dc8e3ac69644eef19f4aa55d77a21dd2f1
+DIST QLivePlayer-3.22.0.tar.gz 640034 BLAKE2B 2038a1b003140525dd03ec14fb357b36826c28d3744133781622b89aee1c973db94ba823c2c64697eb1a3bc77a633f37e6deec14b2678c632f34f853c4881104 SHA512 cd8f7255c101565dd1b90d9e9a7faedfff7b423d5a8d5f7cd0d35d0e991ce28f06b2631a90e9c4d8f787daa0ceb921004a206eaa1a25332a8c592f57c282ab11
diff --git a/media-video/qliveplayer/qliveplayer-3.22.0.ebuild b/media-video/qliveplayer/qliveplayer-3.22.0.ebuild
new file mode 100644
index 000000000..532060f97
--- /dev/null
+++ b/media-video/qliveplayer/qliveplayer-3.22.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit xdg cmake optfeature python-single-r1 readme.gentoo-r1
+
+MY_P="QLivePlayer-${PV}"
+
+DESCRIPTION="A player and recorder for live streams and videos with danmaku support"
+HOMEPAGE="https://github.com/IsoaSFlus/QLivePlayer"
+SRC_URI="https://github.com/IsoaSFlus/QLivePlayer/archive/${PV}.tar.gz -> ${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPEND="
+ ${PYTHON_DEPS}
+ >=dev-qt/qtcore-5.15:5
+ >=dev-qt/qtdeclarative-5.15:5
+ >=dev-qt/qtgui-5.15:5
+ >=dev-qt/qtnetwork-5.15:5
+ >=dev-qt/qtwidgets-5.15:5
+"
+RDEPEND="
+ ${COMMON_DEPEND}
+ $(python_gen_cond_dep '
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ ')
+ media-video/ffmpeg
+ media-video/mpv
+ net-misc/curl
+ >=dev-qt/qtquickcontrols-5.15:5
+ >=dev-qt/qtquickcontrols2-5.15:5
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ kde-frameworks/extra-cmake-modules:5
+"
+
+src_prepare()
+{
+ xdg_environment_reset
+ cmake_src_prepare
+ # respect PYTHON_SINGLE_TARGET
+ grep 'p.start("python3", args);' src/qlphelper/bilivideo.cpp >/dev/null || die
+ sed -i "s/python3/${EPYTHON}/" src/qlphelper/bilivideo.cpp || die
+ grep 'dmcPyProcess->start("python3", dmcPy);' \
+ src/qlphelper/danmakulauncher.cpp >/dev/null || die
+ sed -i "s/python3/${EPYTHON}/" src/qlphelper/danmakulauncher.cpp || die
+ grep 'proc->start("python3", args);' \
+ src/qlphelper/streamfinder.cpp >/dev/null || die
+ sed -i "s/python3/${EPYTHON}/" src/qlphelper/streamfinder.cpp || die
+}
+
+src_install()
+{
+ cmake_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst()
+{
+ xdg_pkg_postinst
+ readme.gentoo_print_elog
+ optfeature "twitch support" "net-misc/streamlink"
+ optfeature "youtube support" "dev-python/protobuf-python net-misc/streamlink"
+}