aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicola Smaniotto <smaniotto.nicola@gmail.com>2022-05-03 14:05:42 +0200
committerNicola Smaniotto <smaniotto.nicola@gmail.com>2022-05-03 14:14:09 +0200
commit40fae481d93710a0e0bd875fbb63cfad2b8eb873 (patch)
tree41075825f6b81d6b28b45c1ef3c5b5215cadcfea
parentmpv-plugin/mpv-autosub: initial import (diff)
downloadguru-40fae481.tar.gz
guru-40fae481.tar.bz2
guru-40fae481.zip
mpv-plugin/mpv-plugin-xrandr: initial import
Signed-off-by: Nicola Smaniotto <smaniotto.nicola@gmail.com>
-rw-r--r--mpv-plugin/mpv-plugin-xrandr/Manifest1
-rw-r--r--mpv-plugin/mpv-plugin-xrandr/metadata.xml8
-rw-r--r--mpv-plugin/mpv-plugin-xrandr/mpv-plugin-xrandr-20190523.ebuild23
3 files changed, 32 insertions, 0 deletions
diff --git a/mpv-plugin/mpv-plugin-xrandr/Manifest b/mpv-plugin/mpv-plugin-xrandr/Manifest
new file mode 100644
index 000000000..baadbc993
--- /dev/null
+++ b/mpv-plugin/mpv-plugin-xrandr/Manifest
@@ -0,0 +1 @@
+DIST mpv-plugin-xrandr-20190523.tar.gz 11494 BLAKE2B adea2b56bb99a919edd4aa6802b7da78440213cb2dd3ecdeef009ee96ad936a8ca257056f6c751dacacc1630f767853b74574633f75c9c777e8c78625875fe50 SHA512 410a1331720bda2c1f3d910fda883a25aeace80c04ef1a35a4962858a944b58342454e8f503676245bc84d675ae1a7d7c15922d978abda58295d5ffc524a36f3
diff --git a/mpv-plugin/mpv-plugin-xrandr/metadata.xml b/mpv-plugin/mpv-plugin-xrandr/metadata.xml
new file mode 100644
index 000000000..be3f1030e
--- /dev/null
+++ b/mpv-plugin/mpv-plugin-xrandr/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM 'https://www.gentoo.org/dtd/metadata.dtd'>
+<pkgmetadata>
+ <maintainer type="person">
+ <email>smaniotto.nicola@gmail.com</email>
+ <name>Nicola Smaniotto</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/mpv-plugin/mpv-plugin-xrandr/mpv-plugin-xrandr-20190523.ebuild b/mpv-plugin/mpv-plugin-xrandr/mpv-plugin-xrandr-20190523.ebuild
new file mode 100644
index 000000000..6f920bb75
--- /dev/null
+++ b/mpv-plugin/mpv-plugin-xrandr/mpv-plugin-xrandr-20190523.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_MPV="rdepend"
+MPV_REQ_USE="lua"
+inherit mpv-plugin
+
+COMMIT="d4e06881367fdcd21572ae9f2d3280ffb5815f26"
+MY_P="${PN}-${COMMIT}"
+
+DESCRIPTION="Automatically invoke the xrandr to set the parameters for the display output"
+HOMEPAGE="https://gitlab.com/lvml/mpv-plugin-xrandr"
+
+SRC_URI="https://gitlab.com/lvml/${PN}/-/archive/${COMMIT}/${MY_P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64"
+
+S="${WORKDIR}/${MY_P}"
+
+MPV_PLUGIN_FILES=( xrandr.lua )