aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2024-01-02 12:33:11 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2024-01-02 12:33:11 +0500
commit45ff42e7f7d26ccb42b5283b1469367bff7ffffd (patch)
tree7b9cfaf1d7a4fd335e1dfb0329551284c105dbb6
parentx11-wm/phoc: add 0.33.0 (diff)
downloadguru-45ff42e7.tar.gz
guru-45ff42e7.tar.bz2
guru-45ff42e7.zip
gui-apps/phosh-tour: new package, add 0.28.0
Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
-rw-r--r--gui-apps/phosh-tour/Manifest1
-rw-r--r--gui-apps/phosh-tour/metadata.xml11
-rw-r--r--gui-apps/phosh-tour/phosh-tour-0.28.0.ebuild47
3 files changed, 59 insertions, 0 deletions
diff --git a/gui-apps/phosh-tour/Manifest b/gui-apps/phosh-tour/Manifest
new file mode 100644
index 0000000000..0d4e5ef888
--- /dev/null
+++ b/gui-apps/phosh-tour/Manifest
@@ -0,0 +1 @@
+DIST phosh-tour-v0.28.0.tar.bz2 120380 BLAKE2B 629bd6eae4cca4d65d0725299d6d6303d32056b46c5df9109ffd9558f81d1e206acbd160c3ff244a328f42d33438d44642f31a2f77389cebb3dd60d793229ca8 SHA512 0c49f8bf0d89399fec5e67480374f1f396d01bb47a01906111395b7df37e33eaac6255c7374a7313edd6c1c7e3b5b829695e7a564b2b204036d045484bc77a63
diff --git a/gui-apps/phosh-tour/metadata.xml b/gui-apps/phosh-tour/metadata.xml
new file mode 100644
index 0000000000..ceaeeda064
--- /dev/null
+++ b/gui-apps/phosh-tour/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>cyber+gentoo@sysrq.in</email>
+ <name>Anna</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="gnome-gitlab">guidog/phosh-tour</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/gui-apps/phosh-tour/phosh-tour-0.28.0.ebuild b/gui-apps/phosh-tour/phosh-tour-0.28.0.ebuild
new file mode 100644
index 0000000000..c28a966e2f
--- /dev/null
+++ b/gui-apps/phosh-tour/phosh-tour-0.28.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2-utils meson xdg
+
+MY_P="${PN}-v${PV}"
+DESCRIPTION="Introduction to phosh on smartphones"
+HOMEPAGE="https://gitlab.gnome.org/guidog/phosh-tour"
+SRC_URI="https://gitlab.gnome.org/guidog/${PN}/-/archive/v${PV}/${MY_P}.tar.bz2"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ dev-libs/glib:2
+ >=gui-libs/gtk-4.4:4
+ >=gui-libs/libadwaita-1.1:1
+"
+RDEPEND="${DEPEND}"
+BDEPEND="sys-devel/gettext"
+
+src_configure() {
+ local emesonargs=(
+ -Dbrand="smartphone"
+ -Dvendor="Gentoo"
+ )
+ meson_src_configure
+}
+
+src_test() {
+ # No useful tests
+ :
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}