aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny (tastytea) Gutbrod <gentoo@tastytea.de>2021-05-25 12:38:30 +0200
committerRonny (tastytea) Gutbrod <gentoo@tastytea.de>2021-05-25 12:42:49 +0200
commit46a004b1bc95f92ce2c306c5dc7ed8900960b9b2 (patch)
tree3cc11af04d940a47407520f2fed9ce01cd9ae6a9
parentmedia-video/uxplay: new package (diff)
downloadguru-46a004b1.tar.gz
guru-46a004b1.tar.bz2
guru-46a004b1.zip
dev-cpp/termcolor: New package.
Header-only library for printing colored messages to the terminal, dependency for app-text/epubgrep. Signed-off-by: Ronny (tastytea) Gutbrod <gentoo@tastytea.de>
-rw-r--r--dev-cpp/termcolor/Manifest1
-rw-r--r--dev-cpp/termcolor/metadata.xml11
-rw-r--r--dev-cpp/termcolor/termcolor-2.0.0.ebuild28
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-cpp/termcolor/Manifest b/dev-cpp/termcolor/Manifest
new file mode 100644
index 000000000..49924bd31
--- /dev/null
+++ b/dev-cpp/termcolor/Manifest
@@ -0,0 +1 @@
+DIST termcolor-2.0.0.tar.gz 88582 BLAKE2B 3e7a4a99af3586fff103d0de0601e019881745e2921b4750dbf476439138a71120b6513a287c5fe26fd96a9c6115cb82295810d9bea11d0992f48fcd5d0a8d18 SHA512 72dead77fb9f3ff79432b1659b57c3d961a57b46305937acd0c221f5abb016f609dfaf7a9bf508bd7a073338ee604cf55f9915c8e8a76ddfaf6c68bc031e37f9
diff --git a/dev-cpp/termcolor/metadata.xml b/dev-cpp/termcolor/metadata.xml
new file mode 100644
index 000000000..6e2037282
--- /dev/null
+++ b/dev-cpp/termcolor/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo@tastytea.de</email>
+ <name>Ronny (tastytea) Gutbrod</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/ikalnytskyi/termcolor/issues</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-cpp/termcolor/termcolor-2.0.0.ebuild b/dev-cpp/termcolor/termcolor-2.0.0.ebuild
new file mode 100644
index 000000000..c8ec44777
--- /dev/null
+++ b/dev-cpp/termcolor/termcolor-2.0.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Header-only library for printing colored messages to the terminal"
+HOMEPAGE="https://termcolor.readthedocs.io/"
+SRC_URI="https://github.com/ikalnytskyi/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ local mycmakeargs=(
+ "-DTERMCOLOR_TESTS=$(usex test)"
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ "${BUILD_DIR}"/test_termcolor || die
+}