aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVitaly Zdanevich <zdanevich.vitaly@ya.ru>2024-03-24 14:32:12 +0400
committerVitaly Zdanevich <zdanevich.vitaly@ya.ru>2024-03-24 14:32:12 +0400
commit470cf060b5b0fac0d7c84e54bad34b9b577f1fe5 (patch)
tree0a4f86c54fe0bc8539029afe2dbcc05542e0dfe3
parentsys-fs/dua-cli: add 2.29.0 (diff)
downloadguru-470cf060b5b0fac0d7c84e54bad34b9b577f1fe5.tar.gz
guru-470cf060b5b0fac0d7c84e54bad34b9b577f1fe5.tar.bz2
guru-470cf060b5b0fac0d7c84e54bad34b9b577f1fe5.zip
sys-boot/boot-repair-iso-download: new package
Signed-off-by: Vitaly Zdanevich <zdanevich.vitaly@ya.ru>
-rw-r--r--sys-boot/boot-repair-iso-download/Manifest1
-rw-r--r--sys-boot/boot-repair-iso-download/boot-repair-iso-download-9999.ebuild36
-rw-r--r--sys-boot/boot-repair-iso-download/metadata.xml12
3 files changed, 49 insertions, 0 deletions
diff --git a/sys-boot/boot-repair-iso-download/Manifest b/sys-boot/boot-repair-iso-download/Manifest
new file mode 100644
index 000000000..54c2ca538
--- /dev/null
+++ b/sys-boot/boot-repair-iso-download/Manifest
@@ -0,0 +1 @@
+DIST boot-repair-disk-64bit.iso 2630877184 BLAKE2B 66b977f030bd673d6b212e8975ae1662f92644e23186046748165cbd6088d2a5ca3dbc419e39d136e112b97263e6494bfca952f5fa1e00d9c2e272748bce994e SHA512 2908bc9b7cb249fe1fefa02d8c817857f59a95b61a896b220d6b056cde2de2fc418654ec09e9576b1fe72eb225b457bc151d56eebc720b5ee8e0e825dba5de22
diff --git a/sys-boot/boot-repair-iso-download/boot-repair-iso-download-9999.ebuild b/sys-boot/boot-repair-iso-download/boot-repair-iso-download-9999.ebuild
new file mode 100644
index 000000000..55cb61a48
--- /dev/null
+++ b/sys-boot/boot-repair-iso-download/boot-repair-iso-download-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Ubuntu based ISO to fix GRUB problems - just downloads to /opt/distribs/"
+HOMEPAGE="https://sourceforge.net/p/boot-repair-cd/home/Home/"
+
+SRC_URI="https://yer.dl.sourceforge.net/project/boot-repair-cd/boot-repair-disk-64bit.iso"
+
+S="${WORKDIR}"
+
+LICENSE="GPL-3"
+SLOT="0"
+PROPERTIES="live"
+RESTRICT="strip"
+QA_PREBUILT="*"
+
+src_install() {
+
+ mkdir -p "$ED/opt/distribs/" || die
+
+ cd "$DISTDIR"
+
+ cp boot-repair-disk-64bit.iso "$ED/opt/distribs/" || die
+}
+
+pkg_postinst() {
+ einfo "To write to USB we have many options, but the simplest one without installing any software:"
+ einfo "sudo cp boot-repair-disk-64bit.iso /dev/sdX"
+ einfo "it will override the data on USB"
+ einfo "Instead of sdX - choose the letter of your USB flash from lsblk"
+ einfo "or"
+ einfo "sudo dd if=boot-repair-disk-64bit.iso of=/dev/sdX"
+ einfo "With dd you can press Ctrl-T to see the progress"
+}
diff --git a/sys-boot/boot-repair-iso-download/metadata.xml b/sys-boot/boot-repair-iso-download/metadata.xml
new file mode 100644
index 000000000..c58921bd3
--- /dev/null
+++ b/sys-boot/boot-repair-iso-download/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <name>Vitaly Zdanevich</name>
+ <email>zdanevich.vitaly@ya.ru</email>
+ </maintainer>
+ <upstream>
+ <doc lang="en">https://help.ubuntu.com/community/Boot-Repair</doc>
+ <remote-id type="sourceforge">boot-repair-cd</remote-id>
+ </upstream>
+</pkgmetadata>