aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHuang Rui <vowstar@gmail.com>2024-04-24 10:29:28 +0800
committerHuang Rui <vowstar@gmail.com>2024-04-24 10:29:28 +0800
commit480050b72787b21405f3ef3eb54cc05d5fb41655 (patch)
tree1c7495a9d228937dfdfae946f34dfac5164b01d3
parentapp-doc/geeknote: Add RESTRICT="test" (diff)
downloadguru-480050b72787b21405f3ef3eb54cc05d5fb41655.tar.gz
guru-480050b72787b21405f3ef3eb54cc05d5fb41655.tar.bz2
guru-480050b72787b21405f3ef3eb54cc05d5fb41655.zip
dev-embedded/nxp-gui-guider: new package, add 1.7.2
Signed-off-by: Huang Rui <vowstar@gmail.com>
-rw-r--r--dev-embedded/nxp-gui-guider/Manifest1
-rw-r--r--dev-embedded/nxp-gui-guider/metadata.xml35
-rw-r--r--dev-embedded/nxp-gui-guider/nxp-gui-guider-1.7.2.ebuild74
3 files changed, 110 insertions, 0 deletions
diff --git a/dev-embedded/nxp-gui-guider/Manifest b/dev-embedded/nxp-gui-guider/Manifest
new file mode 100644
index 000000000..531e49ce5
--- /dev/null
+++ b/dev-embedded/nxp-gui-guider/Manifest
@@ -0,0 +1 @@
+DIST Gui-Guider-Setup-1.7.2-GA.deb 162466906 BLAKE2B 55fdbbac820c8844ee7d7747d4c6bb4138667c369ce7a08e85fcdaa9989fb73a240b9b62c55373612a12335b6e2d6955e2c4f07558497d38a8bf1bce835b0884 SHA512 a873d9304a0b1d8687cff69956e6ff2d3eaa8111c5b5f038c5beefb8da1ca8c21e43ef17ccbb277c49fd212140a350dd4d70445968d1acf00b4a2d3535cb3458
diff --git a/dev-embedded/nxp-gui-guider/metadata.xml b/dev-embedded/nxp-gui-guider/metadata.xml
new file mode 100644
index 000000000..ec4d2ea50
--- /dev/null
+++ b/dev-embedded/nxp-gui-guider/metadata.xml
@@ -0,0 +1,35 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>vowstar@gmail.com</email>
+ <name>Huang Rui</name>
+ </maintainer>
+ <longdescription lang="en">
+ GUI Guider is a user-friendly graphical user interface development tool
+ from NXP that enables the rapid development of high quality display
+ with the open-source LVGL graphics library. GUI Guider's drag-and-drop
+ editor makes it easy to utilize the many features of LVGL such as
+ widgets, animations and styles to create a GUI with minimal or no coding
+ at all.
+ With the click of a button, you can run your application in a simulated
+ environment or export it to a target project. Generated code from GUI
+ Guider can easily be added to an MCUXpresso IDE or IAR Embedded
+ Workbench project, accelerating the development process and allowing you
+ to seamlessly add an embedded user interface to your application.
+ GUI Guider is free to use with NXP’s general purpose and crossover MCUs,
+ and includes built in project templates for several supported platforms.
+ </longdescription>
+ <longdescription lang="zh">
+ GUI Guider 是 NXP 推出的一款用户友好的图形用户界面开发工具,可利用开源
+ LVGL 图形库快速开发高质量显示器。 GUI Guider 的拖放编辑器可以轻松利用
+ LVGL 的许多功能(例如小部件、动画和样式)来创建 GUI,只需最少的编码或
+ 根本不需要编码。
+ 只需单击按钮,您就可以在模拟环境中运行应用程序或将其导出到目标项目。
+ GUI Guider 生成的代码可以轻松添加到 MCUXpresso IDE 或 IAR Embedded
+ Workbench 项目中,从而加速开发过程,并允许您将嵌入式用户界面无缝添加到您
+ 的应用程序中。
+ GUI Guider 可免费与 NXP 的通用和交叉 MCU 一起使用,并包含适用于多个受
+ 支持平台的内置项目模板。
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-embedded/nxp-gui-guider/nxp-gui-guider-1.7.2.ebuild b/dev-embedded/nxp-gui-guider/nxp-gui-guider-1.7.2.ebuild
new file mode 100644
index 000000000..1a88bfe7b
--- /dev/null
+++ b/dev-embedded/nxp-gui-guider/nxp-gui-guider-1.7.2.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+inherit desktop unpacker xdg
+
+DESCRIPTION="GUI Guider is a user-friendly GUI development tool for LVGL"
+HOMEPAGE="https://www.nxp.com/design/design-center/software/development-software/gui-guider"
+SRC_URI="
+ Gui-Guider-Setup-${PV}-GA.deb
+"
+S="${WORKDIR}"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+
+RESTRICT="bindist fetch strip"
+
+RDEPEND="
+ dev-libs/libappindicator
+ dev-libs/libffi
+ dev-libs/nss
+ media-libs/libsdl2
+ media-libs/vips
+ x11-libs/libnotify
+ x11-libs/libXtst
+"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-util/patchelf"
+
+QA_PREBUILT="*"
+DOCS=( "opt/Gui-Guider/EULA.txt" )
+
+pkg_nofetch() {
+ einfo "${PN} requires you to accept their license agreement before downloading."
+ einfo "Download ${SRC_URI}"
+ einfo "with your browser and place it in DISTDIR (usually /var/cache/distfiles/)"
+ einfo "Please place the ${P} installation file ${SRC_URI}"
+ einfo "in your \$\{DISTDIR\}."
+}
+
+src_install() {
+ insinto "/opt"
+ doins -r opt/Gui-Guider
+ # Fix RPATHs to ensure the libraries can be found
+ pushd "${D}/opt/Gui-Guider" || die
+ for f in $(find .) ; do
+ [[ -f "${f}" && $(od -t x1 -N 4 "${f}") == *"7f 45 4c 46"* ]] || continue
+ fperms 0755 "/opt/Gui-Guider/${f}"
+ [[ "${f: -4}" != ".cfx" ]] || continue
+ patchelf --set-rpath "/opt/Gui-Guider" "${f}" || die "patchelf failed on ${f}"
+ done
+ popd || die
+ for f in $(find "${D}/opt/Gui-Guider/environment/LinkServer/linux/binaries") ; do
+ [[ -f "${f}" && $(od -t x1 -N 4 "${f}") == *"7f 45 4c 46"* ]] || continue
+ [[ "${f: -4}" != ".cfx" ]] || continue
+ patchelf --set-rpath \
+"/opt/Gui-Guider/environment/LinkServer/linux/binaries:\
+/opt/Gui-Guider/environment/LinkServer/linux/dist:\
+/opt/Gui-Guider/environment/LinkServer/linux/MCU-LINK_installer/bin:\
+/opt/Gui-Guider/environment/LinkServer/linux/dist/lib-dynload" \
+ "${f}" || die "patchelf failed on ${f}"
+ done
+ for i in 16 32 64 128 256 512; do
+ png_file="usr/share/icons/hicolor/${i}x${i}/apps/Gui-Guider.png"
+ if [ -e "${png_file}" ]; then
+ newicon -s "${i}" "${png_file}" "Gui-Guider.png"
+ fi
+ done
+ domenu "usr/share/applications/Gui-Guider.desktop"
+ einstalldocs
+}