aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Freyermuth <o.freyermuth@googlemail.com>2021-04-23 00:18:09 +0200
committerOliver Freyermuth <o.freyermuth@googlemail.com>2021-04-23 00:18:09 +0200
commit48ba306a591d62cad7b1b8d91d7822c414377ea1 (patch)
tree60537f02ff7cd04a7828b927c13792b77d17c233
parentapp-misc/far2l: various changes and cleanups (diff)
downloadguru-48ba306a.tar.gz
guru-48ba306a.tar.bz2
guru-48ba306a.zip
media-video/mpv-mpris: Do not call cc directly.
Closes: https://bugs.gentoo.org/785124 Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Oliver Freyermuth <o.freyermuth@googlemail.com>
-rw-r--r--media-video/mpv-mpris/mpv-mpris-0.5.ebuild8
-rw-r--r--media-video/mpv-mpris/mpv-mpris-9999.ebuild8
2 files changed, 14 insertions, 2 deletions
diff --git a/media-video/mpv-mpris/mpv-mpris-0.5.ebuild b/media-video/mpv-mpris/mpv-mpris-0.5.ebuild
index 025424181..ef693dac1 100644
--- a/media-video/mpv-mpris/mpv-mpris-0.5.ebuild
+++ b/media-video/mpv-mpris/mpv-mpris-0.5.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit toolchain-funcs
+
DESCRIPTION="MPRIS plugin for mpv"
HOMEPAGE="https://github.com/hoyon/mpv-mpris"
@@ -27,6 +29,10 @@ DOCS=(
README.md
)
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
src_install() {
insinto "/usr/$(get_libdir)/mpv"
doins mpris.so
diff --git a/media-video/mpv-mpris/mpv-mpris-9999.ebuild b/media-video/mpv-mpris/mpv-mpris-9999.ebuild
index 025424181..ef693dac1 100644
--- a/media-video/mpv-mpris/mpv-mpris-9999.ebuild
+++ b/media-video/mpv-mpris/mpv-mpris-9999.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit toolchain-funcs
+
DESCRIPTION="MPRIS plugin for mpv"
HOMEPAGE="https://github.com/hoyon/mpv-mpris"
@@ -27,6 +29,10 @@ DOCS=(
README.md
)
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
src_install() {
insinto "/usr/$(get_libdir)/mpv"
doins mpris.so