aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-10-16 10:56:50 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-10-16 12:21:04 +0200
commit491507ad868b2be7a4af11e72bf05bd82382b920 (patch)
tree49783475235a3d9e41b0d81b2d2e74b757fc8e27
parentapp-shells/clownfish: initial import (diff)
downloadguru-491507ad.tar.gz
guru-491507ad.tar.bz2
guru-491507ad.zip
app-shells/fishtape: initial import
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
-rw-r--r--app-shells/fishtape/Manifest1
-rw-r--r--app-shells/fishtape/fishtape-3.0.1.ebuild34
-rw-r--r--app-shells/fishtape/metadata.xml11
3 files changed, 46 insertions, 0 deletions
diff --git a/app-shells/fishtape/Manifest b/app-shells/fishtape/Manifest
new file mode 100644
index 000000000..e0e0eec8b
--- /dev/null
+++ b/app-shells/fishtape/Manifest
@@ -0,0 +1 @@
+DIST fishtape-3.0.1.tar.gz 4740 BLAKE2B 8bac0eaa9950a036ac4b137d45e5868bcdfaa18a7a7a385f3f44fbee8effd5370d0a58389c3a7202565e7153386f5fa03acbf14571b7e63f928e6ce0b96af92b SHA512 0237b2e816052de23408560ce4244a26c83901a68aab50b5ff883799d6eaa55deb8274a7ce7e319e0a904aa35e8d0e9f97398cc7ef3ae5e911d782dffc83660a
diff --git a/app-shells/fishtape/fishtape-3.0.1.ebuild b/app-shells/fishtape/fishtape-3.0.1.ebuild
new file mode 100644
index 000000000..d1291056d
--- /dev/null
+++ b/app-shells/fishtape/fishtape-3.0.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="100% pure-Fish test runner"
+HOMEPAGE="https://github.com/jorgebucaran/fishtape"
+SRC_URI="https://github.com/jorgebucaran/fishtape/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="app-shells/fish"
+DEPEND="
+ ${RDEPEND}
+ test? ( app-shells/fishtape )
+"
+
+DOCS=( README.md )
+RESTRICT="!test? ( test )"
+
+src_install() {
+ insinto "/usr/share/fish/vendor_completions.d"
+ doins completions/*
+ insinto "/usr/share/fish/vendor_functions.d"
+ doins functions/*
+ einstalldocs
+}
+
+src_test() {
+ fish -c 'fishtape tests/*' || die
+}
diff --git a/app-shells/fishtape/metadata.xml b/app-shells/fishtape/metadata.xml
new file mode 100644
index 000000000..3e857af97
--- /dev/null
+++ b/app-shells/fishtape/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>lssndrbarbieri@gmail.com</email>
+ <name>Alessandro Barbieri</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">jorgebucaran/fishtape</remote-id>
+ </upstream>
+</pkgmetadata>