aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-07-05 02:42:45 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-07-05 02:43:18 +0200
commit4a5259196038d7dd221e7a927d9ebcf9c5310e6a (patch)
tree64a61f457f4fa3c20dde7c7cc378bc79834060b1
parentdev-python/pypandoc: bump (diff)
downloadguru-4a525919.tar.gz
guru-4a525919.tar.bz2
guru-4a525919.zip
dev-python/yara-python: link to libyara.so
Closes: https://bugs.gentoo.org/800260 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
-rw-r--r--dev-python/yara-python/files/yara-python-4.1.0-system-libyara.patch10
-rw-r--r--dev-python/yara-python/yara-python-4.1.0.ebuild9
2 files changed, 16 insertions, 3 deletions
diff --git a/dev-python/yara-python/files/yara-python-4.1.0-system-libyara.patch b/dev-python/yara-python/files/yara-python-4.1.0-system-libyara.patch
new file mode 100644
index 0000000000..dd27400737
--- /dev/null
+++ b/dev-python/yara-python/files/yara-python-4.1.0-system-libyara.patch
@@ -0,0 +1,10 @@
+--- a/setup.py
++++ b/setup.py
+@@ -370,5 +370,6 @@
+ 'update': UpdateCommand},
+ ext_modules=[Extension(
+ name='yara',
+- include_dirs=['yara/libyara/include', 'yara/libyara/', '.'],
++ include_dirs=['/usr/include', 'yara/libyara/include', 'yara/libyara/', '.'],
++ libraries=['yara'],
+ sources=['yara-python.c'])])
diff --git a/dev-python/yara-python/yara-python-4.1.0.ebuild b/dev-python/yara-python/yara-python-4.1.0.ebuild
index 0f524d839b..32a20b842e 100644
--- a/dev-python/yara-python/yara-python-4.1.0.ebuild
+++ b/dev-python/yara-python/yara-python-4.1.0.ebuild
@@ -1,11 +1,12 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
+#with pypy3 undefined symbol: PyDescr_NewGetSet
+PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1 eutils
+inherit distutils-r1
DESCRIPTION="Python interface for a malware identification and classification tool"
HOMEPAGE="https://github.com/VirusTotal/yara-python"
@@ -21,6 +22,8 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/${P}-system-libyara.patch" )
+
distutils_enable_tests setup.py
compile_python() {