aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Breathitt Gray <vilhelm.gray@gmail.com>2020-12-28 18:08:35 -0500
committerWilliam Breathitt Gray <vilhelm.gray@gmail.com>2020-12-28 18:14:01 -0500
commit4b1221ec3844153cdb4b251eb457053ed20dd42c (patch)
treec00f3a83cf3534395ab7ce743ef973294a46c0a1
parentdev-vcs/gitahead: rm bundled openssl (diff)
downloadguru-4b1221ec.tar.gz
guru-4b1221ec.tar.bz2
guru-4b1221ec.zip
dev-lang/fbc-bootstrap: New package
Signed-off-by: William Breathitt Gray <vilhelm.gray@gmail.com>
-rw-r--r--dev-lang/fbc-bootstrap/Manifest1
-rw-r--r--dev-lang/fbc-bootstrap/fbc-bootstrap-1.07.2.ebuild26
-rw-r--r--dev-lang/fbc-bootstrap/files/fbc-1.07.0-Pass-ltinfo-to-linker.patch25
-rw-r--r--dev-lang/fbc-bootstrap/metadata.xml17
4 files changed, 69 insertions, 0 deletions
diff --git a/dev-lang/fbc-bootstrap/Manifest b/dev-lang/fbc-bootstrap/Manifest
new file mode 100644
index 000000000..7b009089e
--- /dev/null
+++ b/dev-lang/fbc-bootstrap/Manifest
@@ -0,0 +1 @@
+DIST FreeBASIC-1.07.2-source-bootstrap.tar.xz 10700992 BLAKE2B e7016e5f58ae79086c0445bf6a09f33d4335af771422778be407e3351d583522e16f137763e471ba88e47b4318ab5bd2aec882ef5e5ff85cc334b0eccf27fdc5 SHA512 f381d14343496f68d3401ad1a66ff4fb1314270eddebb72ed2bc5624b856c4b29e7e14062f531a5158d892bb73d9aa80ff54fe7c260b4b8967b1330d26b2ecfc
diff --git a/dev-lang/fbc-bootstrap/fbc-bootstrap-1.07.2.ebuild b/dev-lang/fbc-bootstrap/fbc-bootstrap-1.07.2.ebuild
new file mode 100644
index 000000000..747c02a56
--- /dev/null
+++ b/dev-lang/fbc-bootstrap/fbc-bootstrap-1.07.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Bootstrap package for dev-lang/fbc"
+HOMEPAGE="https://www.freebasic.net"
+SRC_URI="https://github.com/freebasic/fbc/releases/download/${PV}/FreeBASIC-${PV}-source-bootstrap.tar.xz"
+
+LICENSE="FDL-1.2 GPL-2+ LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=( "${FILESDIR}"/fbc-1.07.0-Pass-ltinfo-to-linker.patch )
+
+S="${WORKDIR}/FreeBASIC-${PV}-source-bootstrap"
+
+src_compile() {
+ emake bootstrap-minimal
+}
+
+src_install() {
+ newbin bin/fbc fbc-bootstrap
+ emake DESTDIR="${D}" prefix="/usr/share/freebasic-bootstrap" TARGET=${CHOST} install-includes
+ emake DESTDIR="${D}" prefix="/usr/share/freebasic-bootstrap" TARGET=${CHOST} install-rtlib
+}
diff --git a/dev-lang/fbc-bootstrap/files/fbc-1.07.0-Pass-ltinfo-to-linker.patch b/dev-lang/fbc-bootstrap/files/fbc-1.07.0-Pass-ltinfo-to-linker.patch
new file mode 100644
index 000000000..72bd51faf
--- /dev/null
+++ b/dev-lang/fbc-bootstrap/files/fbc-1.07.0-Pass-ltinfo-to-linker.patch
@@ -0,0 +1,25 @@
+From c62adcd85c4e9d8b793a7a4f71fc88f6fbb79798 Mon Sep 17 00:00:00 2001
+From: William Breathitt Gray <vilhelm.gray@gmail.com>
+Date: Tue, 27 Aug 2019 20:41:07 +0900
+Subject: [PATCH] Pass -ltinfo to linker
+
+---
+ makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/makefile b/makefile
+index e093bb1..eb3f759 100644
+--- a/makefile
++++ b/makefile
+@@ -1109,7 +1109,7 @@ endif
+ # Use gcc to link fbc from the bootstrap .o's
+ # (assuming the rtlib was built already)
+ ifneq ($(filter darwin freebsd linux netbsd openbsd solaris,$(TARGET_OS)),)
+- BOOTSTRAP_LIBS := -lncurses -lm -pthread
++ BOOTSTRAP_LIBS := -ltinfo -lncurses -lm -pthread
+ endif
+ $(BOOTSTRAP_FBC): rtlib $(BOOTSTRAP_OBJ)
+ $(QUIET_LINK)$(CC) -o $@ $(libdir)/fbrt0.o bootstrap/$(FBTARGET)/*.o $(libdir)/libfb.a $(BOOTSTRAP_LIBS)
+--
+2.22.1
+
diff --git a/dev-lang/fbc-bootstrap/metadata.xml b/dev-lang/fbc-bootstrap/metadata.xml
new file mode 100644
index 000000000..5ef896cc9
--- /dev/null
+++ b/dev-lang/fbc-bootstrap/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription lang="en">
+ This package is used only to boot strap <pkg>dev-lang/fbc</pkg>.
+ It is not meant to be used by end users directly.
+ </longdescription>
+ <maintainer type="person">
+ <email>vilhelm.gray@gmail.com</email>
+ <name>William Breathitt Gray</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/freebasic/fbc/issues</bugs-to>
+ <doc lang="en">https://www.freebasic.net</doc>
+ <remote-id type="github">freebasic/fbc</remote-id>
+ </upstream>
+</pkgmetadata>