aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-10-07 12:06:11 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-10-07 12:22:45 +0200
commit4b57775c07db488724946ae9f8f34f6ec8bf5a26 (patch)
treeed10d1142f153abf3d634d835163e511c92af7e3
parentdev-python/rstr: build with pyproject (diff)
downloadguru-4b57775c.tar.gz
guru-4b57775c.tar.bz2
guru-4b57775c.zip
dev-python/orjson: EAPI 8
Closes: https://bugs.gentoo.org/816738 Closes: https://bugs.gentoo.org/816735 Closes: https://bugs.gentoo.org/816732 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
-rw-r--r--dev-python/orjson/orjson-3.5.3-r1.ebuild (renamed from dev-python/orjson/orjson-3.5.3.ebuild)23
1 files changed, 11 insertions, 12 deletions
diff --git a/dev-python/orjson/orjson-3.5.3.ebuild b/dev-python/orjson/orjson-3.5.3-r1.ebuild
index 3dc01d0d5..ee55a96ae 100644
--- a/dev-python/orjson/orjson-3.5.3.ebuild
+++ b/dev-python/orjson/orjson-3.5.3-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
CRATES="
ahash-0.7.4
@@ -39,7 +39,17 @@ CRATES="
"
DISTUTILS_SINGLE_IMPL=1
DISTUTILS_USE_SETUPTOOLS=no
+EPYTEST_DESELECT=(
+ test/test_datetime.py::DatetimeTests::test_datetime_pendulum_positive
+ test/test_datetime.py::DatetimeTests::test_datetime_partial_second_pendulum_supported
+ test/test_datetime.py::DatetimeTests::test_datetime_pendulum_negative_dst
+ test/test_datetime.py::DatetimeTests::test_datetime_pendulum_negative_non_dst
+ test/test_datetime.py::DatetimeTests::test_datetime_partial_hour
+ test/test_datetime.py::DatetimeTests::test_datetime_pendulum_partial_hour
+ test/test_api.py::ApiTests::test_version
+)
PYTHON_COMPAT=( python3_{8..9} )
+QA_FLAGS_IGNORED="*"
inherit cargo distutils-r1
@@ -97,14 +107,3 @@ src_install() {
python_domodule orjson/orjson*.so
dodoc README.md
}
-
-python_test() {
- epytest -vv \
- --deselect test/test_datetime.py::DatetimeTests::test_datetime_pendulum_positive \
- --deselect test/test_datetime.py::DatetimeTests::test_datetime_partial_second_pendulum_supported \
- --deselect test/test_datetime.py::DatetimeTests::test_datetime_pendulum_negative_dst \
- --deselect test/test_datetime.py::DatetimeTests::test_datetime_pendulum_negative_non_dst \
- --deselect test/test_datetime.py::DatetimeTests::test_datetime_partial_hour \
- --deselect test/test_datetime.py::DatetimeTests::test_datetime_pendulum_partial_hour \
- || die
-}