aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKurt Kanzenbach <kurt@kmk-computers.de>2022-06-24 19:55:40 +0200
committerKurt Kanzenbach <kurt@kmk-computers.de>2022-06-24 19:55:40 +0200
commit4ba39e5392d4ec87f0d3c5c37aa89f942a526508 (patch)
treeca30de3e7badf84726b0cd70390f80ed2144da3b
parentdev-lang/opencilk: fix installation (diff)
downloadguru-4ba39e53.tar.gz
guru-4ba39e53.tar.bz2
guru-4ba39e53.zip
net-dialup/tio: add 1.40
Signed-off-by: Kurt Kanzenbach <kurt@kmk-computers.de>
-rw-r--r--net-dialup/tio/Manifest1
-rw-r--r--net-dialup/tio/tio-1.40.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/net-dialup/tio/Manifest b/net-dialup/tio/Manifest
index 5a3b9e2f6..83ee7628c 100644
--- a/net-dialup/tio/Manifest
+++ b/net-dialup/tio/Manifest
@@ -1 +1,2 @@
DIST tio-1.38.tar.xz 1806556 BLAKE2B e8a02e4349b4b4ea27887031fdcce79bd99914b85710a005b1dc5328aea98ec175e6991920d85df7c9acf9c0557dfc3c31005c19c62ca7d28ac7bba08896753f SHA512 d702c907460abd3c15d051f185592d5ec9245734016e299960a4a102724e28208bb21b71cb3cba7919cd2197f338470297034401c7978bcd207195b548e8a2b9
+DIST tio-1.40.tar.xz 3069480 BLAKE2B 5d5ef6478fa80eecf96599c6c55a77fd8e2b9259fd44fab105ee5f6c6b5494d5656599374f7ffe43741c7925a2bedac4c593ad8695abd6ba9ceca559f9272d4c SHA512 41f92d757fea3099e9974c64736aa75f69961ba5baf7b01cdb281656bcbf6490afe3748ce49c080624b5f4d3493a8398b8d702be0423f2bcbd0f0484bf76fdf6
diff --git a/net-dialup/tio/tio-1.40.ebuild b/net-dialup/tio/tio-1.40.ebuild
new file mode 100644
index 000000000..aa1af5f4e
--- /dev/null
+++ b/net-dialup/tio/tio-1.40.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson bash-completion-r1
+
+DESCRIPTION="Simple TTY terminal application"
+HOMEPAGE="https://tio.github.io/"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+SLOT="0"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-libs/inih
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dbashcompletiondir="$(get_bashcompdir)"
+ )
+
+ meson_src_configure
+}