aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@protonmail.com>2020-09-28 09:26:13 +0200
committerMaciej Barć <xgqt@protonmail.com>2020-09-28 09:26:13 +0200
commit4c09ae41afdecd7c9f1f842749e9e40715f0083b (patch)
treeb347ceb186317ca70a441c9013e8f5d34b669b22
parentdev-python/redbaron: bump to 0.9.2; add python3_8 impl compat (diff)
downloadguru-4c09ae41afdecd7c9f1f842749e9e40715f0083b.tar.gz
guru-4c09ae41afdecd7c9f1f842749e9e40715f0083b.tar.bz2
guru-4c09ae41afdecd7c9f1f842749e9e40715f0083b.zip
dev-python/pure-protobuf: bump to 2.0.1; add python3_8 impl compat
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Maciej Barć <xgqt@protonmail.com>
-rw-r--r--dev-python/pure-protobuf/Manifest1
-rw-r--r--dev-python/pure-protobuf/pure-protobuf-2.0.0-r1.ebuild2
-rw-r--r--dev-python/pure-protobuf/pure-protobuf-2.0.1.ebuild23
3 files changed, 25 insertions, 1 deletions
diff --git a/dev-python/pure-protobuf/Manifest b/dev-python/pure-protobuf/Manifest
index 2bfe6a066..b69eeb270 100644
--- a/dev-python/pure-protobuf/Manifest
+++ b/dev-python/pure-protobuf/Manifest
@@ -1 +1,2 @@
DIST pure-protobuf-2.0.0.tar.gz 17576 BLAKE2B 49979559b3c08eb9abdddfa80e78ca4d953347a005b042d5b69aa4c6caef185c358408b1bf54d9161c0cadf69422b1ed033c74b324e947328c55f8b6ec4fd050 SHA512 a8d5211f34d0d6fab28d8b54fb3bb87d41a13b61a01f6f79f47fc1c0eafaf1ab17ddfd323c1035fcd4794b7b23823f48f38af3aa485835683f824cdd4689b098
+DIST pure-protobuf-2.0.1.tar.gz 17818 BLAKE2B 8c2e44d8b3f1a36ee6a5835abfc6cbd6728f913a7a79f90807310e292ac5947e91bbcac6fd02d4bf9c5830eac38d66e90ec869c38289bd7f906590b786cdef0a SHA512 8a14eca81009fd81526552b6556ba6a86fac1fb3d65ab560ff6b547ffd64dde53cc0f66ddfba66df89ea46a13f40442cf3bddb0f0da4b78465380845e6f6ab19
diff --git a/dev-python/pure-protobuf/pure-protobuf-2.0.0-r1.ebuild b/dev-python/pure-protobuf/pure-protobuf-2.0.0-r1.ebuild
index 5cb93b655..74b598c95 100644
--- a/dev-python/pure-protobuf/pure-protobuf-2.0.0-r1.ebuild
+++ b/dev-python/pure-protobuf/pure-protobuf-2.0.0-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_7 )
+PYTHON_COMPAT=( python3_{7,8} )
inherit distutils-r1
diff --git a/dev-python/pure-protobuf/pure-protobuf-2.0.1.ebuild b/dev-python/pure-protobuf/pure-protobuf-2.0.1.ebuild
new file mode 100644
index 000000000..3e370a83c
--- /dev/null
+++ b/dev-python/pure-protobuf/pure-protobuf-2.0.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="A more Pythonic version of doxypy, a Doxygen filter for Python"
+HOMEPAGE="
+ https://github.com/eigenein/protobuf
+ https://pypi.org/project/pure-protobuf/
+"
+SRC_URI="https://github.com/eigenein/protobuf/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+S="${WORKDIR}/protobuf-${PV}"
+
+distutils_enable_tests pytest