aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJay Faulkner <jay@jvf.cc>2022-09-01 18:47:15 -0700
committerJay Faulkner <jay@jvf.cc>2022-09-01 19:09:24 -0700
commit4c77f8f888abd2553fc03a6c54d6c0a2a0424b69 (patch)
tree909d5693d3ef088ed4cf55f76f82a8ba3eb53576
parentapp-misc/ledger-live: destabilize 2.43.1 for ~amd64 (diff)
downloadguru-4c77f8f8.tar.gz
guru-4c77f8f8.tar.bz2
guru-4c77f8f8.zip
sys-power/tlp: Remove unneeded use flags
The systemd and elogind toggles in the tlp build only toggle installation of unit file and sleep triggers. There's no need to conditionally install those per PG#0301. Signed-Off-By: Jay Faulkner <jay@jvf.cc>
-rw-r--r--sys-power/tlp/tlp-1.5.0.ebuild15
1 files changed, 6 insertions, 9 deletions
diff --git a/sys-power/tlp/tlp-1.5.0.ebuild b/sys-power/tlp/tlp-1.5.0.ebuild
index 0fc6f0d01..bf18bbbb7 100644
--- a/sys-power/tlp/tlp-1.5.0.ebuild
+++ b/sys-power/tlp/tlp-1.5.0.ebuild
@@ -12,25 +12,22 @@ S="${WORKDIR}/TLP-${PV}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64"
-IUSE="bash-completion elogind systemd"
RESTRICT="mirror"
+# It's uncertain if elogind/systemd is actually required, however, without the sleep
+# hooks working, which require one of them, it doesn't seem like this app is very useful.
RDEPEND="virtual/udev
- bash-completion? ( app-shells/bash app-shells/bash-completion )
- elogind? ( sys-auth/elogind )
- systemd? ( sys-apps/systemd )"
+ || ( sys-auth/elogind sys-apps/systemd )"
DEPEND="${RDEPEND}"
-REQUIRED_USE="?? ( elogind systemd )"
src_install() {
emake \
DESTDIR="${D}" \
TLP_NO_INIT=1 \
- TLP_NO_BASHCOMP=$(usex bash-completion 0 1) \
- TLP_WITH_ELOGIND=$(usex elogind 1 0) \
- TLP_WITH_SYSTEMD=$(usex systemd 1 0) \
+ TLP_WITH_ELOGIND=1 \
+ TLP_WITH_SYSTEMD=1 \
install install-man
- chmod 444 "${D}/usr/share/tlp/defaults.conf" # manpage says this file should not be edited
+ fperms 444 "/usr/share/tlp/defaults.conf" # manpage says this file should not be edited
newinitd "${FILESDIR}/tlp.init" tlp
keepdir "/var/lib/tlp" # created by Makefile, probably important
}